Autocomplete of URL hangs for minutes when EverSync add-on is enabled

VERIFIED FIXED

Status

Tech Evangelism
Add-ons
VERIFIED FIXED
9 months ago
9 months ago

People

(Reporter: James Rome, Unassigned)

Tracking

Firefox 52
x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

9 months ago
Created attachment 8836029 [details]
autolookup.png

Aside from taking minutes to accept input from me when FF starts, when I start typing in the URL, it hangs for minutes. Firefox has become quite unusable.

Comment 1

9 months ago
Does the same thing happen in safe mode? (Help > restart with add-ons disabled)
Component: General → Untriaged
Flags: needinfo?(jamesrome)
(Reporter)

Comment 2

9 months ago
in safe mode, it was much faster. But it still paused for a minute accessing a web page for me (a local one!). I deleted a bunch of add-ons. I now have the list in the attached image (you cannot select the items on the add-on page to cut and paste!). With this reduced set, it is still slow on the autocomplete.
Flags: needinfo?(jamesrome)
(Reporter)

Comment 3

9 months ago
Created attachment 8836140 [details]
addons.png

There also seeme to be no way to remove the non-allowed addons.

Comment 4

9 months ago
(In reply to James Rome from comment #3)
> Created attachment 8836140 [details]
> addons.png
> 
> There also seeme to be no way to remove the non-allowed addons.

Andrew, do you know if this is normal? I would have supposed it would be possible to remove add-ons that were disabled because of missing/wrong signatures...

(In reply to James Rome from comment #2)
> in safe mode, it was much faster.

OK, good.

> But it still paused for a minute accessing
> a web page for me (a local one!).

So, it seems there are two problems. For this one (slowness accessing a webpage) and the other one (slow autocomplete) a performance profile is going to be really helpful. Note that the latter might be caused by add-ons, but the performance profile would still help narrow that down, and perhaps point to Firefox code that might help make things perform better.

https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem should help in generating a profile you can then share and link to in this bug. Given there are two problems, we'll probably need 2 performance profiles.

> I deleted a bunch of add-ons. I now have
> the list in the attached image (you cannot select the items on the add-on
> page to cut and paste!). With this reduced set, it is still slow on the
> autocomplete.

If you go to about:support (also accessible via Help > Troubleshooting Information) it has a list of add-ons that you can copy. In fact, it also has a lot more information that you can easily copy as readable text using the buttons on the page, and then attach (as a text file) to this bug - which might still help in addition to the perf profiles (which are probably more important).

Comment 5

9 months ago
(In reply to :Gijs from comment #4)
> (In reply to James Rome from comment #3)
> > Created attachment 8836140 [details]
> > addons.png
> > 
> > There also seeme to be no way to remove the non-allowed addons.
> 
> Andrew, do you know if this is normal? I would have supposed it would be
> possible to remove add-ons that were disabled because of missing/wrong
> signatures...
> 
> (In reply to James Rome from comment #2)
> > in safe mode, it was much faster.
> 
> OK, good.
> 
> > But it still paused for a minute accessing
> > a web page for me (a local one!).
> 
> So, it seems there are two problems. For this one (slowness accessing a
> webpage) and the other one (slow autocomplete) a performance profile is
> going to be really helpful. Note that the latter might be caused by add-ons,
> but the performance profile would still help narrow that down, and perhaps
> point to Firefox code that might help make things perform better.
> 
> https://developer.mozilla.org/en-US/docs/Mozilla/Performance/
> Reporting_a_Performance_Problem should help in generating a profile you can
> then share and link to in this bug. Given there are two problems, we'll
> probably need 2 performance profiles.
> 
> > I deleted a bunch of add-ons. I now have
> > the list in the attached image (you cannot select the items on the add-on
> > page to cut and paste!). With this reduced set, it is still slow on the
> > autocomplete.
> 
> If you go to about:support (also accessible via Help > Troubleshooting
> Information) it has a list of add-ons that you can copy. In fact, it also
> has a lot more information that you can easily copy as readable text using
> the buttons on the page, and then attach (as a text file) to this bug -
> which might still help in addition to the perf profiles (which are probably
> more important).

Now with needinfos to the relevant people...
Flags: needinfo?(jamesrome)
Flags: needinfo?(aswan)

Comment 6

9 months ago
An extension that can be disabled but not removed typically means that it is in a location that you do not have direct write access to, such as the system-wide directories documented at
https://developer.mozilla.org/en-US/Add-ons/Installing_extensions

This bug is labeled with Platform="Mac OS X" on which the corresponding directory is /Library/Application Support/Mozilla/Extensions.  If you have write permissions there, you can remove (or rename) individual xpi files there.  But of course if other people share this computer with you, they then won't be able to use those extensions any more.  Also note that these extensions were not installed through Firefox, they were probably installed as a side effect of installing some other piece of software directly on your Mac, you may want to remove those entirely (though I don't think that's a particularly easy thing to do on the Mac unfortunately...)
Flags: needinfo?(aswan)

Updated

9 months ago
Flags: needinfo?(jamesrome)

Updated

9 months ago
Flags: needinfo?(jamesrome)
(Reporter)

Comment 7

9 months ago
Sorry this has taken a while, but I have been fighting Comcast...
The performance profiler itself hangs. So by the time it comes back, the startup issues are already past.
Flags: needinfo?(jamesrome)

Comment 8

9 months ago
(In reply to James Rome from comment #7)
> Sorry this has taken a while, but I have been fighting Comcast...
> The performance profiler itself hangs. So by the time it comes back, the
> startup issues are already past.

OK. Mike, do you have any ideas how to debug this further?
Flags: needinfo?(mconley)
LastPass is a known bad actor, performance-wise. If you disable that add-on, does performance improve?
Flags: needinfo?(mconley) → needinfo?(jamesrome)
(Reporter)

Comment 10

9 months ago
Disabling LastPass did nothing. I put a movie of what I see on my dropbox.
https://www.dropbox.com/s/2quxkpzv37fweg6/Screen%20Recording%202017-02-17%20at%202.25.11%20PM.mov?dl=0
AndI attach the info file from your debugger.
Flags: needinfo?(jamesrome)
(Reporter)

Comment 11

9 months ago
Created attachment 8838679 [details]
JvivOTZO.dms

The dms file
(Reporter)

Comment 12

9 months ago
Created attachment 8838680 [details]
profiler.png

what I see from your profiler
(In reply to James Rome from comment #12)
> Created attachment 8838680 [details]
> profiler.png
> 
> what I see from your profiler

Okay, this is very useful, thank you. I can see a big hang in the main thread here. The profile is not symbolicated, but we've got JS stacks here, and I can see that the hang is happening within some sync code that, I believe, is going over all of the bookmarks in some folder and generating GUIDs.

Hey kit, any idea why Firefox might be spending so much time in this profile doing bookmark queries? Is this a symptom of corrupted bookmarks or something?

Profile: https://cleopatra.io/#report=63bbd14c796e56981b1a23b9e165e9d656e73209&selection=0,1,2,3,4,5,3,6,3,7,8,3,9,3,10,3,11,3,12,3,13,3,14,3,10,3,15,3,16,3,17,3,18,3,19,20,3,21,3,22,3,4,4,23,24,3,25,26,3,27,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,30,3,28,29,3,31,3,32,3,28,29,3,33,34,3,35,3,36,3,35,3,199
Flags: needinfo?(kit)
Thanks very much for uploading the profile! Unfortunately, that's not Firefox Sync. :-( From the Add-ons DXR, it looks like that's coming from the EverSync add-on.

I suspect the reason it's spending so much time in the profile is because it's using the synchronous history API (https://dxr.mozilla.org/addons/source/addons/375008/modules/partial/bmkservice.js#636-722), which executes DB queries on the main thread.
Flags: needinfo?(kit)
Ah, my mistake! I saw sync in the name and just assumed. My apologies, kit!

James - if you disable the EverSync add-on, does the performance improve?
Flags: needinfo?(jamesrome)
(Reporter)

Comment 16

9 months ago
yes, that does seen to speed things up
Flags: needinfo?(jamesrome)

Comment 17

9 months ago
Thanks James, Kit and Mike for your research here! Looks like this is an issue with the EverSync add-on...

Jorge/Andreas, do we have contacts for the EverSync people so we can make them aware of this and potentially get this fixed on their end?
Component: Untriaged → Add-ons
Flags: needinfo?(jorge)
Flags: needinfo?(awagner)
Product: Firefox → Tech Evangelism
Summary: Autocomplete of URL hangs for minutes → Autocomplete of URL hangs for minutes when EverSync add-on is enabled
Version: 52 Branch → Firefox 52
I reached out to the author through our review tools.

Keeping my need-info for future follow-up.
Flags: needinfo?(jorge)

Comment 19

9 months ago
Hi,

We fixed it and uploaded new version. Please review.

Thank you for contacting us and letting us know!
A new version (13.1.1) has just been approved that should fix the issue.

James, could you please test again with the new version and let us know whether it fixes the issue for you?
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(awagner) → needinfo?(jamesrome)
Resolution: --- → FIXED
(Reporter)

Comment 21

9 months ago
Seems to have fixed it.
Flags: needinfo?(jamesrome)

Comment 22

9 months ago
(In reply to James Rome from comment #21)
> Seems to have fixed it.

\o/

Thanks everyone.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.