If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ion-compile JSOP_SPREADCALLARRAY

RESOLVED DUPLICATE of bug 1338920

Status

()

Core
JavaScript Engine: JIT
P1
normal
RESOLVED DUPLICATE of bug 1338920
8 months ago
7 months ago

People

(Reporter: evilpie, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
This should probably be as simple as using the same code as for JSOP_NEWARRAY. The documentation Opcodes.h has some comment about avoid unboxed arrays, but I don't think that really needs any special attention. Arai points out it's probably used here: https://dxr.mozilla.org/mozilla-central/rev/0eef1d5a39366059677c6d7944cfe8a97265a011/js/src/vm/ObjectGroup.cpp#1517.

Unboxed-arrays are disabled by default.
Priority: -- → P1
(Reporter)

Comment 1

7 months ago
This is a trivial part of bug 1338920.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1338920
You need to log in before you can comment on or make changes to this bug.