Closed Bug 1338975 Opened 4 years ago Closed 4 years ago

Crash in java.lang.IllegalStateException: at android.os.Parcel.readException(Parcel.java)

Categories

(Firefox for Android :: Audio/Video, defect)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: njn, Assigned: jhlin)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-e57b80e3-329e-4727-a8f9-711b12170212.
=============================================================

This is the #1 topcrash in Aurora 20170210084116, with 25 occurrences. It's also showing up a bit on Nightly. There's a bit of variety in the Java stack traces, though they all seem to go through ICodec.java.

Looks like it first started happening in January.

Jim, any ideas?
Flags: needinfo?(nchen)
Flags: needinfo?(nchen) → needinfo?(jolin)
Looks like some exceptions were not caught in remote decoder and leaked to local proxy.
Assignee: nobody → jolin
Flags: needinfo?(jolin)
Comment on attachment 8837404 [details]
Bug 1338975 - Don't leak MediaCodec exceptions to CodecProxy.

https://reviewboard.mozilla.org/r/112544/#review114298
Attachment #8837404 - Flags: review?(nchen) → review+
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/959ce2584a80
Don't leak MediaCodec exceptions to CodecProxy. r=jchen
https://hg.mozilla.org/mozilla-central/rev/959ce2584a80
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(jolin)
Comment on attachment 8837404 [details]
Bug 1338975 - Don't leak MediaCodec exceptions to CodecProxy.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1338975
[User impact if declined]: browser crash when playing video/audio.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: it catches more exceptions from codec 
[String changes made/needed]: none
Flags: needinfo?(jolin)
Attachment #8837404 - Flags: approval-mozilla-aurora?
Comment on attachment 8837404 [details]
Bug 1338975 - Don't leak MediaCodec exceptions to CodecProxy.

Fix a crash. Aurora53+.
Attachment #8837404 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.