Crash in mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::dom::ContentChild::FatalErrorIfNotUsingGPUProcess | libxul.so@0xd8d46b | mozilla::layers::PCompositorBridgeChild::SendPTextureConstructor

RESOLVED DUPLICATE of bug 1298158

Status

()

Core
Graphics
P3
critical
RESOLVED DUPLICATE of bug 1298158
a year ago
2 months ago

People

(Reporter: sylvestre, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-b891dc40-775e-41d2-b624-ec0a92170213.
=============================================================

I was on google doc. 
I have a bunch of graphic glitches lately.

Frame 	Module 	Signature 	Source
0 	firefox 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:33
1 	libxul.so 	NS_DebugBreak 	xpcom/base/nsDebugImpl.cpp:449
2 	libxul.so 	mozilla::ipc::FatalError 	ipc/glue/ProtocolUtils.cpp:302
3 	libxul.so 	mozilla::dom::ContentChild::FatalErrorIfNotUsingGPUProcess 	dom/ipc/ContentChild.cpp:3134
4 	libxul.so 	libxul.so@0xd8d46b 	
5 	libxul.so 	mozilla::layers::PCompositorBridgeChild::SendPTextureConstructor 	obj-firefox/ipc/ipdl/PCompositorBridgeChild.cpp:1143
6 	libxul.so 	mozilla::layers::CompositorBridgeChild::CreateTexture 	gfx/layers/ipc/CompositorBridgeChild.cpp:1033
7 	libxul.so 	mozilla::layers::TextureClient::InitIPDLActor(mozilla::layers::CompositableForwarder*) 	
8 	libxul.so 	mozilla::layers::ContentClientRemoteBuffer::CreateBackBuffer(mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&) 	
9 	libxul.so 	mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback(mozilla::layers::ReadbackProcessor*) 	
10 	libxul.so 	mozilla::layers::ClientContainerLayer::RenderLayer 	gfx/layers/client/ClientContainerLayer.h:57
11 	libxul.so 	mozilla::layers::ClientContainerLayer::RenderLayer 	gfx/layers/client/ClientLayerManager.h:361
12 	libxul.so 	mozilla::layers::ClientLayerManager::EndTransactionInternal(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	
13 	libxul.so 	mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	
14 	libxul.so 	nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) 	
15 	libxul.so 	nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, nsDisplayListBuilderMode, nsLayoutUtils::PaintFrameFlags) 	
16 	libxul.so 	mozilla::PresShell::Paint(nsView*, nsRegion const&, unsigned int) 	
17 	libxul.so 	nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) 	
18 	libxul.so 	nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) 	
19 	libxul.so 	nsViewManager::ProcessPendingUpdates() 	
20 	libxul.so 	nsRefreshDriver::Tick(long, mozilla::TimeStamp) 	
21 	libxul.so 	nsRefreshDriver::DoTick() 	
22 	libxul.so 	nsRefreshDriver::NotifyTransactionCompleted 	layout/base/nsRefreshDriver.cpp:2105
23 	libxul.so 	libxul.so@0xfbeb24

Comment 1

a year ago
GraphicsCriticalError kept printing message in [1] to indicate CreateBuffer() allocates fails with reasonable destBufferRect. The last error message for GraphicsCriticalError was showed in [2]. 

Also noted that CreateBackBuffer in frame 8 was called from [3]. The fail reason may be run out of memory. Dumping memory report may get more information.

[1]:https://dxr.mozilla.org/mozilla-central/source/gfx/layers/RotatedBuffer.cpp#670
[2]: [C45][GFX1-]: Failed 2 buffer db=0 dw=0 for 1168, 2531, 64, 26 (t=7.86165)
[3]:https://dxr.mozilla.org/mozilla-central/source/gfx/layers/RotatedBuffer.cpp#665

Updated

a year ago
Whiteboard: [gfx-noted]
Priority: -- → P3
(Reporter)

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298158
You need to log in before you can comment on or make changes to this bug.