Note: There are a few cases of duplicates in user autocompletion which are being worked on.

WebRequest.onErrorOcurred doesn't get timeouts

RESOLVED DUPLICATE of bug 1149250

Status

()

Toolkit
WebExtensions: Request Handling
P1
normal
RESOLVED DUPLICATE of bug 1149250
5 months ago
3 months ago

People

(Reporter: jkt, Assigned: mixedpuppy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webRequest] triaged)

(Reporter)

Description

5 months ago
I am working on an extension: https://github.com/jonathanKingston/fix-my-http which is rewriting URLs on the fly to be HTTPS.

However it isn't catching any form of timeouts on the page via WebRequest.onCompleted or onErrorOcurred.

My test URL is: https://itv.com which just spins until it doesn't respond.

I would like some way to pickup errors like this, it doesn't have to be through onErrorOcurred etc.

Updated

5 months ago
Priority: -- → P1
Whiteboard: [webRequest] triaged

Updated

5 months ago
Assignee: nobody → mixedpuppy
(Assignee)

Comment 1

4 months ago
I'm pretty sure this is not a timeout issue, but is bug 1149250.

Specifically I have a test that basically is the same as:

https://github.com/jonathanKingston/fix-my-http/blob/master/background.js#L48

Changing protocol from http to https is a failure point.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149250
(Assignee)

Comment 2

4 months ago
jkt, I think you were going to provide a simplified example, just wanted to touch base before it pops out of my brain buffer.
Flags: needinfo?(jkt)
(Assignee)

Comment 3

3 months ago
no response, removing ni
Flags: needinfo?(jkt)
You need to log in before you can comment on or make changes to this bug.