stylo: test_animations.html fatally asserts with IsGecko() from KeyframeEffectReadOnly

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: xidorn, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

./mach mochitest --disable-e10s layout/style/test/test_animations.html

Stack:
Assertion failure: IsGecko(), at c:\mozilla-source\stylo\obj-firefox-stylo\dist\include\mozilla/StyleSetHandle.h:74
#01: mozilla::dom::KeyframeEffectReadOnly::ResolveBaseStyle (c:\mozilla-source\stylo\dom\animation\keyframeeffectreadonly.cpp:368)
#02: mozilla::dom::KeyframeEffectReadOnly::EnsureBaseStyles (c:\mozilla-source\stylo\dom\animation\keyframeeffectreadonly.cpp:459)
#03: mozilla::dom::KeyframeEffectReadOnly::UpdateProperties (c:\mozilla-source\stylo\dom\animation\keyframeeffectreadonly.cpp:293)
#04: mozilla::dom::KeyframeEffectReadOnly::SetKeyframes (c:\mozilla-source\stylo\dom\animation\keyframeeffectreadonly.cpp:210)
#05: CSSAnimationBuilder::Build (c:\mozilla-source\stylo\layout\style\nsanimationmanager.cpp:668)
#06: nsAnimationManager::BuildAnimations (c:\mozilla-source\stylo\layout\style\nsanimationmanager.cpp:1110)
#07: nsAnimationManager::UpdateAnimations (c:\mozilla-source\stylo\layout\style\nsanimationmanager.cpp:426)
#08: mozilla::ServoStyleSet::GetContext (c:\mozilla-source\stylo\layout\style\servostyleset.cpp:179)
#09: mozilla::ServoStyleSet::GetContext (c:\mozilla-source\stylo\layout\style\servostyleset.cpp:144)
#10: mozilla::ServoStyleSet::ResolveStyleFor (c:\mozilla-source\stylo\layout\style\servostyleset.cpp:217)
#11: mozilla::StyleSetHandle::Ptr::ResolveStyleFor (c:\mozilla-source\stylo\obj-firefox-stylo\dist\include\mozilla\stylesethandleinlines.h:95)
#12: nsCSSFrameConstructor::ResolveStyleContext (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:5037)
#13: nsCSSFrameConstructor::ResolveStyleContext (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:5007)
#14: nsCSSFrameConstructor::AddFrameConstructionItems (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:5655)
#15: nsCSSFrameConstructor::ContentAppended (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:7504)
#16: nsCSSFrameConstructor::CreateNeededFrames (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:7162)
#17: nsCSSFrameConstructor::CreateNeededFrames (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:7163)
#18: nsCSSFrameConstructor::CreateNeededFrames (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:7163)
#19: nsCSSFrameConstructor::CreateNeededFrames (c:\mozilla-source\stylo\layout\base\nscssframeconstructor.cpp:7181)
#20: mozilla::ServoRestyleManager::ProcessPendingRestyles (c:\mozilla-source\stylo\layout\base\servorestylemanager.cpp:355)
#21: mozilla::PresShell::FlushPendingNotifications (c:\mozilla-source\stylo\layout\base\presshell.cpp:4197)
#22: nsDocument::FlushPendingNotifications (c:\mozilla-source\stylo\dom\base\nsdocument.cpp:7956)
#23: nsComputedDOMStyle::UpdateCurrentStyleSources (c:\mozilla-source\stylo\layout\style\nscomputeddomstyle.cpp:819)
#24: nsComputedDOMStyle::GetPropertyCSSValue (c:\mozilla-source\stylo\layout\style\nscomputeddomstyle.cpp:977)
#25: nsComputedDOMStyle::GetPropertyValue (c:\mozilla-source\stylo\layout\style\nscomputeddomstyle.cpp:403)
#26: nsComputedDOMStyle::GetPropertyValue (c:\mozilla-source\stylo\layout\style\nscomputeddomstyle.cpp:341)
#27: mozilla::dom::CSS2PropertiesBinding::get_marginTop (c:\mozilla-source\stylo\obj-firefox-stylo\dom\bindings\css2propertiesbinding.cpp:25732)
#28: mozilla::dom::GenericBindingGetter (c:\mozilla-source\stylo\dom\bindings\bindingutils.cpp:2849)
#29: js::CallJSNative (c:\mozilla-source\stylo\js\src\jscntxtinlines.h:281)
#30: js::InternalCallOrConstruct (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:460)
#31: js::CallGetter (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:638)
#32: CallGetter (c:\mozilla-source\stylo\js\src\vm\nativeobject.cpp:1806)
#33: GetExistingProperty<1> (c:\mozilla-source\stylo\js\src\vm\nativeobject.cpp:1854)
#34: NativeGetPropertyInline<1> (c:\mozilla-source\stylo\js\src\vm\nativeobject.cpp:2083)
#35: js::NativeGetProperty (c:\mozilla-source\stylo\js\src\vm\nativeobject.cpp:2118)
#36: js::GetProperty (c:\mozilla-source\stylo\js\src\vm\nativeobject.h:1432)
#37: JS_ForwardGetPropertyTo (c:\mozilla-source\stylo\js\src\jsapi.cpp:2556)
#38: mozilla::dom::GetPropertyOnPrototype (c:\mozilla-source\stylo\dom\bindings\bindingutils.cpp:2036)
#39: mozilla::dom::CSS2PropertiesBinding::DOMProxyHandler::get (c:\mozilla-source\stylo\obj-firefox-stylo\dom\bindings\css2propertiesbinding.cpp:65551)
#40: js::Proxy::get (c:\mozilla-source\stylo\js\src\proxy\proxy.cpp:311)
#41: js::GetProperty (c:\mozilla-source\stylo\js\src\vm\nativeobject.h:1432)
#42: js::GetProperty (c:\mozilla-source\stylo\js\src\jsobj.h:844)
#43: js::GetProperty (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:4311)
#44: GetPropertyOperation (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:192)
#45: Interpret (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:2674)
#46: js::RunScript (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:406)
#47: js::ExecuteKernel (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:690)
#48: js::Execute (c:\mozilla-source\stylo\js\src\vm\interpreter.cpp:719)
#49: Evaluate (c:\mozilla-source\stylo\js\src\jsapi.cpp:4555)
#50: Evaluate (c:\mozilla-source\stylo\js\src\jsapi.cpp:4580)
#51: JS::Evaluate (c:\mozilla-source\stylo\js\src\jsapi.cpp:4639)
#52: nsJSUtils::EvaluateString (c:\mozilla-source\stylo\dom\base\nsjsutils.cpp:207)
#53: nsJSUtils::EvaluateString (c:\mozilla-source\stylo\dom\base\nsjsutils.cpp:274)
#54: nsScriptLoader::EvaluateScript (c:\mozilla-source\stylo\dom\base\nsscriptloader.cpp:2242)
#55: nsScriptLoader::ProcessRequest (c:\mozilla-source\stylo\dom\base\nsscriptloader.cpp:2027)
#56: nsScriptLoader::ProcessPendingRequests (c:\mozilla-source\stylo\dom\base\nsscriptloader.cpp:2282)
#57: mozilla::detail::RunnableMethodImpl<nsScriptLoader * __ptr64 const,void (__cdecl nsScriptLoader::*)(void) __ptr64,1,0>::Run (c:\mozilla-source\stylo\obj-firefox-stylo\dist\include\nsthreadutils.h:892)
#58: nsThread::ProcessNextEvent (c:\mozilla-source\stylo\xpcom\threads\nsthread.cpp:1262)
#59: NS_ProcessNextEvent (c:\mozilla-source\stylo\xpcom\threads\nsthreadutils.cpp:389)
#60: mozilla::ipc::MessagePump::Run (c:\mozilla-source\stylo\ipc\glue\messagepump.cpp:96)
#61: MessageLoop::RunHandler (c:\mozilla-source\stylo\ipc\chromium\src\base\message_loop.cc:232)
#62: MessageLoop::Run (c:\mozilla-source\stylo\ipc\chromium\src\base\message_loop.cc:212)
#63: nsBaseAppShell::Run (c:\mozilla-source\stylo\widget\nsbaseappshell.cpp:158)
#64: nsAppShell::Run (c:\mozilla-source\stylo\widget\windows\nsappshell.cpp:264)
#65: nsAppStartup::Run (c:\mozilla-source\stylo\toolkit\components\startup\nsappstartup.cpp:283)
#66: XREMain::XRE_mainRun (c:\mozilla-source\stylo\toolkit\xre\nsapprunner.cpp:4458)
#67: XREMain::XRE_main (c:\mozilla-source\stylo\toolkit\xre\nsapprunner.cpp:4635)
#68: XRE_main (c:\mozilla-source\stylo\toolkit\xre\nsapprunner.cpp:4726)
#69: do_main (c:\mozilla-source\stylo\browser\app\nsbrowserapp.cpp:235)
#70: NS_internal_main (c:\mozilla-source\stylo\browser\app\nsbrowserapp.cpp:307)
#71: wmain (c:\mozilla-source\stylo\toolkit\xre\nswindowswmain.cpp:118)
#72: __scrt_common_main_seh (f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253)
#73: BaseThreadInitThunk[C:\WINDOWS\System32\KERNEL32.DLL +0x8364]
#74: RtlUserThreadStart[C:\WINDOWS\SYSTEM32\ntdll.dll +0x670d1]

Comment 1

10 months ago
I think this was caused by my work (bug 1331704).  A patch I am having for bug 1338927 will fix this.
Assignee: nobody → hikezoe
Depends on: 1338927

Comment 2

10 months ago
Fixed by bug 1338927.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
The mochitest is not enabled yet. Reopen for re-enabling that.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Priority: -- → P3
Blocks: 1243581
Closing since test_animations.html has been running for a while.
Assignee: hikezoe → nobody
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.