Closed Bug 1339449 Opened 3 years ago Closed 3 years ago

Re-enable video-replay-after-audio-end.html crashtest (Android emulator)

Categories

(Core :: Audio/Video: Playback, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: jya, Assigned: alwu)

References

Details

(Keywords: regression)

Attachments

(2 files)

Permafailing following bug 1319987 and bug 1336358
jya: next steps here?  getting near to 54 going to aurora.  Who should look at this?
Flags: needinfo?(jyavenard)
(In reply to Randell Jesup [:jesup] from comment #1)
> jya: next steps here?  getting near to 54 going to aurora.  Who should look
> at this?

while treeherder is using supra-slow simulator to run mochitest, I don't think there's much we can do about it.
Flags: needinfo?(jyavenard)
Summary: Re-enable video-replay-after-audio-end.html crashtest → Re-enable video-replay-after-audio-end.html crashtest (Android emulator)
Does it fail on autophone runs?  Those are real HW.

If it doesn't, we add it to the bucket of "too-slow emulator" bugs
Flags: needinfo?(jyavenard)
We need to check this, and disable the test or do something, if it's still happening
Flags: needinfo?(rjesup)
(In reply to Randell Jesup [:jesup] from comment #3)
> Does it fail on autophone runs?  Those are real HW.
> 
> If it doesn't, we add it to the bucket of "too-slow emulator" bugs

Who's the right person to talk to about whether this fails on autophone?  Do those actually show up on treeherder?
Alastor, 
Please check this on autophone. 
Thanks.
Flags: needinfo?(rjesup)
Flags: needinfo?(jyavenard)
Flags: needinfo?(alwu)
The test can pass on my Nexus5 with Android 6.0.1.
Flags: needinfo?(alwu)
Alastor,
Any update?
Flags: needinfo?(alwu)
Let's run the test again to see whether we can re-enable this test.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3ecf9f7cda32b535803b5a290df12ba5ba19ed57
From the try server result, it seems we can enable this test again.
Flags: needinfo?(alwu)
Comment on attachment 8861284 [details]
Bug 1339449 - Re-enable video-replay-after-audio-end.html crashtest.

https://reviewboard.mozilla.org/r/133238/#review136142
Attachment #8861284 - Flags: review?(jyavenard) → review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66311a113b58
Re-enable video-replay-after-audio-end.html crashtest. r=jya
https://hg.mozilla.org/mozilla-central/rev/66311a113b58
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Were you going to check 54 as well?
Assignee: nobody → alwu
Flags: needinfo?(alwu)
Could I push the changed to the branch 54? because I don't sure whether this test can run on 54.
Flags: needinfo?(alwu) → needinfo?(ryanvm)
You can push it to Try on top of a Beta tree, yes. I went ahead and did so to cut down on lag here :)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5045bcde46e243fff302ac1e5f58664f4f10aee0
Flags: needinfo?(ryanvm)
Green on Try, including lots of retriggers. This is test-only, so I'm marking it to ride-along the next time we're pushing there anyway.
Whiteboard: [checkin-needed-beta]
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.