Closed Bug 133962 Opened 18 years ago Closed 18 years ago

Component Manager being held past XPCOM shutdown

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 78861

People

(Reporter: tvl, Assigned: dougt)

Details

mozilla and regxpcom both show this problem.  regxpcom in debug shows this out:

nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0',
file nsXPComInit.cpp, line 582

for embedding onto RO filesystems, one really needs to be able to use regxpcom
to build the registry before making the media.  since it fails with this error,
it makes build process for embedding a bit uglier to get this error eaten, but
keep others that might happen.

*** This bug has been marked as a duplicate of 78861 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
Component: XPCOM Registry → XPCOM
QA Contact: doug.turner → xpcom
You need to log in before you can comment on or make changes to this bug.