Closed Bug 1339672 Opened 3 years ago Closed 1 year ago

[css-grid] grid-auto-columns/rows should accept multiple track-size values

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox54 --- wontfix
firefox70 --- fixed

People

(Reporter: mats, Assigned: boris)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-complete, DevAdvocacy, testcase, Whiteboard: [devRel:P1][wptsync upstream])

Attachments

(3 files)

Attached file testcase
https://drafts.csswg.org/css-grid/#auto-tracks
"
Value: 	<track-size>+
"

(This is an old Grid spec change that happened together with the "simplified subgrid"
changes so we apparently missed it.)
Blocks: css-grid
Keywords: DevAdvocacy
Whiteboard: [devRel:P1]
Duplicate of this bug: 1449751
Blink/Edge/WebKit accept multiple track-size values.
I've just hit this bug too - here's a CodePen -- https://codepen.io/sturobson/pen/b9b47e83d372cc4834aed7585e0e8b52?editors=1100

Would love this to be working :)

This becomes an issue for the classic card-layout subgrid use-case. See https://codepen.io/mirisuzanne/pen/XQGJbe?editors=0100 where it is impossible to establish individual sizing for the three repeating auto-generated rows that would be required.

Assignee: nobody → boris.chiou

Looks like this is a web-compatible issue now, and I guess what we need is update the types of grid-auto-columns & grid-auto-rows, and update nsGridContainerFrame::TrackSizingFunctions to accept an array of auto size.

Support &lt;track-size>+ on the implicit track sizing properties,
grid-auto-columns and grid-auto-rows.

Keywords: dev-doc-needed
Duplicate of this bug: 1392734
Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e4bb211b673
Support multiple track sizes for grid-auto-{columns|rows}. r=emilio,mats
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18302 for changes under testing/web-platform/tests
Whiteboard: [devRel:P1] → [devRel:P1][wptsync upstream]
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Upstream PR merged
Depends on: 1593796
You need to log in before you can comment on or make changes to this bug.