Can't submit a form more than once.

RESOLVED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Juarez Josende do Canto, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020328
BuildID:    2002032803

In the sample files included the frm2 form should be submited as many times as
the user press the OK button in the confirm dialog. But it is submited just the
first time.

Reproducible: Always
Steps to Reproduce:
1.Save the files:

-------------- f1.htm ---------------
<html>
<script>
function OK()
{
	document.frm1.submit();	
}
function Confirma()
{
	document.frm2.submit();
}
</script>
<body>
	<form name=frm1 action='f3.htm' method='get' target=wResposta>
		<input type=button value='Begin' onclick='OK()'>
	</form>
	<form name=frm2 action='f3.htm' method='get' target=wResposta>
	</form>
	<iframe name='wResposta' frameborder='0' FRAMESPACING='0' width='100%'
height='200px' NORESIZE='NORESIZE' SCROLLING='auto' src='f2.htm'></iframe>
</body>
</html>

-------------- f2.htm ---------------
<body bgcolor=#0000ff>
</body>

-------------- f3.htm ---------------
<body bgcolor=#ff0000>
</body>
<script for=window event=onload>
	if(confirm("OK ?")==true)
		parent.Confirma();
	else
	{
		document.write("Cancelado");
		document.close();
	}
</script>

2.Click the 'Begin' button (the 'frm1' is submited)
3.Click the 'OK' button in the 'confirm' dialog. (the 'frm2' is submited)
4.Click the 'OK' button in the 'confirm' dialog again. (the 'frm2' should be
submited again but is not!)




Actual Results:  The frm2 form is submited just once.

Expected Results:  The frm2 form should be submited as many times as the 'OK'
button in the 'confirm' dialog is clicked.

Comment 1

16 years ago
yes, this is with purpose so in order to prevent submitting buy orders twice
just by mistakenly clicking on a submit button twice (this change was made a few
weeks ago and it costed us a bunch of work).

in the future, we might chose to set a timeout or so but is not a decided thing yet.

reassigning to John since he checked in the change ;-)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
in the previous coment alexandru said he reassigned the bug to jkeiser, but the
bug was not reassigned. Doing so.
Assignee: alexsavulov → jkeiser

Updated

16 years ago
Priority: -- → P3
(Assignee)

Comment 3

16 years ago
This bug is directly related to the fact that we do not reload the page when a 
GET submission occurs.  If we don't reload the page the content node will not 
be destroyed and recreated.  Setting dependent on bug 135679, which should fix 
that problem.
Depends on: 135679

Comment 4

16 years ago
wfm. Fixed, or not it works for me.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.