Closed Bug 1339845 Opened 3 years ago Closed 3 years ago

large number of profile-change-net-teardown observers for the main process in about:memory

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1336240
Tracking Status
firefox53 --- fix-optional
firefox54 --- fix-optional

People

(Reporter: froydnj, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [MemShrink])

[Tracking Requested - why for this release]: memory leaks are bad things.

I noticed today in about:memory:

39,672 (100.0%) -- observer-service-suspect
├──28,322 (71.39%) ── referent(topic=profile-change-net-teardown)
├───1,210 (03.05%) ── referent(topic=xpcom-shutdown)

which is an abnormally large number of profile-change-net-teardown observers.

Searching for profile-change-net-teardown yields:

https://dxr.mozilla.org/mozilla-central/search?q=profile-change-net-teardown&redirect=false

We're interested in AddObserver calls with a |false| parameter (indicating the observer service should take a strong reference) with no corresponding RemoveObserver call.  Out of the list above, the nsUpdateService.js call is Gonk-only, so we can ignore that.  The only other call is the one in nsChannelClassifier.cpp, which was added about a month ago in bug 1324820, so it seems like a viable candidate for what might be causing this.

Tentatively setting tracking flags and whatnot.

Thomas, as you were the person who committed the change to nsChannelClassifier, can you investigate this?
Flags: needinfo?(tnguyen)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(tnguyen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1336240
We are tracking in the dupe, changing status so it falls off the release health dashboard.
You need to log in before you can comment on or make changes to this bug.