Firefox 51.x unstable on Linux

RESOLVED DUPLICATE of bug 1335827

Status

()

Firefox
Untriaged
--
critical
RESOLVED DUPLICATE of bug 1335827
10 months ago
10 months ago

People

(Reporter: Eli the Bearded, Unassigned)

Tracking

({crash})

51 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I'm seeing intermittent and non-reproducible crashes of FF 51.0.0 and 51.0.1 on Linux (64 bit). I'm using builds downloaded from Mozilla, not distro versions.




Actual results:

Several times it has crashed with this message:

[1] ###!!! ABORT: RenderFreePicture: RenderBadPicture (invalid Picture parameter): file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 147
[1] ###!!! ABORT: RenderFreePicture: RenderBadPicture (invalid Picture parameter): file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 147

(Yes, doubled.) The first two times that happened was upon closing a window. Later attempts to reproduce it failed, and I have also seen that crash without closing a window.

Last night, left running unattended, it crashed sometime with this message:

ExceptionHandler::GenerateDump cloned child 1778
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...



Expected results:

No crashes. FF49 and FF50 have been very stable for me.
(Reporter)

Updated

10 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

10 months ago
Looks like the fingerprinting demo site http://www.uniquemachine.org/ can reliably crash FF51. Start with a new profile and no plug-ins/config changes different from "as shipped". Then run the fingerprint test. But it might be unrelated, since the error messages (to STDOUT / STDERR) are different:

libGL error: failed to load driver: radeonsi
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[Parent 7857] WARNING: pipe error (61): Connection reset by peer: file /builds/slave/m-rel-l64-00000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 323
[Parent 7857] WARNING: pipe error (51): Connection reset by peer: file /builds/slave/m-rel-l64-00000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 323

###!!! [Parent][MessageChannel] Error: (msgtype=0x2E007F,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

But I've crashed three times in minutes with that site.

Updated

10 months ago
Severity: normal → critical
Keywords: crash

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335827
You need to log in before you can comment on or make changes to this bug.