Entities/numeric character refs not correctly copied to clipboard

VERIFIED DUPLICATE of bug 40350

Status

()

defect
P3
minor
VERIFIED DUPLICATE of bug 40350
20 years ago
19 years ago

People

(Reporter: elig, Assigned: akkzilla)

Tracking

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

<This is probably a known bug, but Akkana didn't know of a bug report for it, and
I can't find one. So, I'm writing it up.

CC:ing Montse, in the event that a tester in International may already have a
pre-existing bug report detailing this issue, since they're more likely to be
using entities.>

* TITLE/SUMMARY
Entities/numeric character refs not correctly copied to clipboard (’, —, etc)

* STEPS TO REPRODUCE
0) Launch Apprunner
1) Copy a slew of the entities from http://www.htmlstylehouse.com/charactr.htm
(or numeric character references like &#151 or &#146.)
2) View the Clipboard (or paste the Clipboard content to a text editor)

* RESULT
 - What happened
Virtually none of the entities are correctly copied to the Clipboard; instead,
other characters appear, instead. e.g. the directional apostraphe (&#146) appears
as a comma, etc.

 - What was expected
Characters that can be successfully copied to the system Clipboard from within IE
or Navigator 4.x should also be copyable from within Mozilla.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (19990808 optimized build)
        Win32 Apprunner (19990808 optimized build [NT 4, Service Pack 3])

 - Can't Reproduce On
        Linux Apprunner (1999082316 [busted] build date; probably this morning's
build.) Copy doesn't function.


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
QA Contact: sujay → elig
[QA Assigning to self; Sujay, in the unlikely event that you have a burning
inclination to be the QA Assigned on this bug report, please feel free to pick it
up.]
Blocks: 12551
Status: NEW → ASSIGNED
Depends on: 8865
Target Milestone: M15
Accepting bug ... but this depends on a more general entity encoding problem,
discussed in 8865.
Changing Component to Output.
This is fixed in most cases, but nsHTMLToTXTSinkStream still needs to be changed
to use the nsISaveAsCharset interface, so I'm leaving this bug open until that
happens.
*** Bug 6748 has been marked as a duplicate of this bug. ***
Bulk move of all "Output" component bugs to new "DOM to Test Conversion" 
component.  Output will be deleted as a component.
Component: Output → DOM to Text Conversion
Severity: normal → minor
Target Milestone: M15 → M20
moving to future milestone
Assignee: akkana → beppe
Status: ASSIGNED → NEW
Target Milestone: M20 → Future
moving back to previous owner
Assignee: beppe → akkana
Re-accepting.
Status: NEW → ASSIGNED
Marking this as a dup of 40350, since I think they're the same issue.

*** This bug has been marked as a duplicate of 40350 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
updating QA contact, eli is gone. akk or sujay, could you verify this please? 
Thanks!
QA Contact: elig → sujay
verified in 9/29 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.