Closed Bug 1340157 Opened 3 years ago Closed 3 years ago

Re-enable omni.ja compression on nightly

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: catlee, Assigned: catlee)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

I'd like to re-enable omni.ja compression on nightly that was disabled in bug 1231379 so we can measure the impact that uncompressed omni.jas have via telemetry, and also so that nightly matches aurora, beta and release.
Assignee: nobody → catlee
Comment on attachment 8838054 [details]
Bug 1340157: Re-enable compression for omni.ja files

https://reviewboard.mozilla.org/r/113066/#review114554
Attachment #8838054 - Flags: review?(ted) → review+
Pushed by catlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29f4d23a9e97
Re-enable compression for omni.ja files r=ted
Whiteboard: [leaveopen]
https://hg.mozilla.org/mozilla-central/rev/29f4d23a9e97
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: leave-open
Whiteboard: [leaveopen]
Target Milestone: Firefox 54 → ---
Depends on: 1340764
Depends on: 1340873
Talos results showed:
* increase in ts_paint (bad, and expected)
* increase in sessionrestore time (bad, and expected)
* decrease in Main_RSS (good, and expected)
* decrease in main_startup_fileio (good, and unexpected)

In contrast, data from Telemetry (looking at data since Feb 17th) seems to show:
* decrease in SIMPLE_MEASURES_FIRSTPAINT (good!) https://mzl.la/2mmbzkD
* decrease in SIMPLE_MEASURES_SESSIONRESTORED (good!) https://mzl.la/2mbwtXC
* decrease in MEMORY_TOTAL (good!) https://mzl.la/2mml3wb

I'm confused by the difference between Talos results and Telemetry.

Given the unclear benefits here, and the fact that we didn't let this ride the trains before, I'm leaning towards leaving omni.jas compressed for now.
in many cases our machines for Talos are not representative of end user machines- but they do provide a good idea if things are good or bad.  

When we move 54 to Aurora, I will check back with this bug unless we resolve it as wontfix (from a talos regression standpoint)
(In reply to Joel Maher ( :jmaher) from comment #7)
> When we move 54 to Aurora, I will check back with this bug unless we resolve
> it as wontfix (from a talos regression standpoint)

Aurora already has omni.ja compressed, because it never had it decompressed in the first place, so nothing will change on aurora.
Based on Telemetry, I'm going to leave the omni.ja files compressed.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
In bug 1362377 we decided to ship uncompressed omni.ja files in Firefox 55.
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.