The compositor thread is missing in profiles

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mstange, Assigned: njn)

Tracking

({regression})

Trunk
mozilla54
regression
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
This started a few days ago, I think.

STR:
 1. In a fresh Firefox profile, install the gecko profiler addon
 2. Get a profile

The resulting profile doesn't have a Compositor thread.
(Assignee)

Comment 1

2 years ago
Probably my fault :)  I'll take a look.
Assignee: nobody → n.nethercote
(Assignee)

Comment 2

2 years ago
(In reply to Nicholas Nethercote [:njn] from comment #1)
> Probably my fault :)  I'll take a look.

Actually, looks like it's something about the compositor itself. I've bisected down to this:

changeset:   342278:a5270cca9e28
parent:      342277:764e2c0ad987
parent:      341825:b9c6246f13ea
user:        Kartikaya Gupta <kgupta@mozilla.com>
date:        Fri Feb 10 13:57:53 2017 -0500
summary:     Merge m-c to graphics

I have a few more iterations to go, but I might not get to them until tomorrow.
(Assignee)

Comment 3

2 years ago
In the end it is my fault.

changeset:   341665:4a894b2316f0
user:        Nicholas Nethercote <nnethercote@mozilla.com>
date:        Wed Feb 08 12:01:41 2017 +1100
summary:     Bug 1337189 (part 16) - Move all the bools out of Sampler. r=mstange.

I haven't yet worked out the problem.
(Assignee)

Comment 4

2 years ago
They must be set before the call to MaybeSetProfiler(), which checks
gProfileThreads, and before the gTaskTracer check.

This patch fixes the failure of some threads (e.g. Compositor) to be profiled,
as well as allowing TaskTracer to start up again!
Attachment #8838519 - Flags: review?(mstange)
(Reporter)

Updated

2 years ago
Attachment #8838519 - Flags: review?(mstange) → review+
(Reporter)

Updated

2 years ago
Blocks: 1337189

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/421a05b31eae
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
You need to log in before you can comment on or make changes to this bug.