Closed Bug 1340491 Opened 5 years ago Closed 5 years ago

ProfileAge without a custom logger supplied spams stdout/stderr when information isn't yet cached in prefs

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

Because of https://dxr.mozilla.org/mozilla-central/rev/0eef1d5a39366059677c6d7944cfe8a97265a011/toolkit/modules/ProfileAge.jsm#27 , if no logger is supplied debug logging is mapped to dump() which for jsms is always on, which means it shows up in stdout/stderr on a clean profile - 1-2 messages for every file in the profile directory. We shouldn't do that.
Duplicate of this bug: 1340549
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8839221 [details]
Bug 1340491 - ProfileAge shouldn't spam stdout/stderr by default,

https://reviewboard.mozilla.org/r/113922/#review115492
Attachment #8839221 - Flags: review?(MattN+bmo) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e69363e8457b
ProfileAge shouldn't spam stdout/stderr by default, r=MattN
https://hg.mozilla.org/mozilla-central/rev/e69363e8457b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.