Closed Bug 1340547 Opened 3 years ago Closed 3 years ago

[WebExtensions] browser.downloads.onDeterminingFilename not found

Categories

(WebExtensions :: Untriaged, defect)

53 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1245652

People

(Reporter: antdlmr, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

Need to capture the FTP downloading.
Google Chrome has usefull chrome.downloads.onDeterminingFilename method.
Firefox does not support it.



Actual results:

Methods webRequest.onBeforeRequest,... does not work
browser.webRequest.onBeforeRequest.addListener( onBeforeRequest, { 
	urls:  [ "http://*/*", "https://*/*", "ftp://*/*" ],
browser.webRequest.onBeforeSendHeaders.addListener( onBeforeSendHeaders, {
	urls:  [ "http://*/*", "https://*/*", "ftp://*/*" ],
.....

How to solve the problem of FTP capture? Tell me please.
Component: Untriaged → WebExtensions: Untriaged
Product: Core → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245652
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.