Closed Bug 1340568 Opened 3 years ago Closed 3 years ago

Not possible to select Firefox as default browser

Categories

(Firefox :: Installer, defect)

54 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
firefox54 --- verified

People

(Reporter: zoelskoeltem03_05_, Assigned: mhowell)

Details

Attachments

(2 files, 9 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170217030229

Steps to reproduce:

Since 3 or 4 days Firefox Nightly is not longer my default browser. I can't select firefox as my default browser. It is not listed as an option.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
You should this that in the options http://i.imgur.com/TNBzXRS.jpg after bug 1338843.
Component: Untriaged → Installer
There's been a string of patches on Nightly that have affected the default browser settings. One of those may have gotten your registry into a strange, inconsistent state. Try running the Nightly installer and letting it "upgrade" your current version (it will say "upgrade" even though you're up to date already), and that should take care of it.
unfortunately, that doesn't solve the problem. In runned the installer and the updater.
If you create a fresh profile for Nightly, is the option visible again?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(zoelskoeltem03_05_)
No, it is still gone. I have this problem also on an other device.
http://imgur.com/a/nOZBs
Could you export following registry keys from Registry Editor and attach the exported file?
HKEY_CURRENT_USER\Software\Clients\StartMenuInternet
HKEY_CURRENT_USER\Software\RegisteredApplications
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet
HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications
Also, when you go to Firefox [Options] > [General], what message is displayed under the [Startup] section?
Component: Installer → Shell Integration
(In reply to Masatoshi Kimura [:emk] from comment #6)
> Could you export following registry keys from Registry Editor and attach the
> exported file?
> HKEY_CURRENT_USER\Software\Clients\StartMenuInternet
> HKEY_CURRENT_USER\Software\RegisteredApplications
> HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet
> HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications

I attached them to this topic. 

(In reply to Masatoshi Kimura [:emk] from comment #7)
> Also, when you go to Firefox [Options] > [General], what message is
> displayed under the [Startup] section?

'Nightly is not your default browser' in Dutch.
Thank you. Then, please attach the following registry keys:
HKEY_CLASSES_ROOT\FirefoxHTML
HKEY_CLASSES_ROOT\FirefoxHTML-A3710B8EBB50CD3
HKEY_CLASSES_ROOT\FirefoxURL
HKEY_CLASSES_ROOT\FirefoxURL-A3710B8EBB50CD3
Attached file HKEY_CLASSES_ROOT-FirefoxHTML.reg (obsolete) —
Attached file HKEY_CLASSES_ROOT-FirefoxURL.reg (obsolete) —
(In reply to Masatoshi Kimura [:emk] from comment #13)
> Thank you. Then, please attach the following registry keys:
> HKEY_CLASSES_ROOT\FirefoxHTML
> HKEY_CLASSES_ROOT\FirefoxHTML-A3710B8EBB50CD3
> HKEY_CLASSES_ROOT\FirefoxURL
> HKEY_CLASSES_ROOT\FirefoxURL-A3710B8EBB50CD3
Done
Thank you very match. I could reproduce the bug with the attached registry file.

Steps to reproduce:
1. Prepare a clean Win10 VM.
2. Install Nightly to the default location (C:\Program Files\Nightly). Use Win64 builds for 64-bit Windows (otherwise the install location will different). Uncheck "Launch Nightly now" at the end of the installer.
3. Import the attached registry key.
4. Launch Nightly.
5. Go to Options > General > Startup and click [Make Default].

Actual result:
Nightly is not listed in the Web browser menu in the Default apps Setting.

Expected result:
Nightly should be listed in the Web browser menu in the Default apps Setting.

We should make the registry manipulation more robust.
Attachment #8839254 - Attachment is obsolete: true
Attachment #8839255 - Attachment is obsolete: true
Attachment #8839256 - Attachment is obsolete: true
Attachment #8839257 - Attachment is obsolete: true
Attachment #8839375 - Attachment is obsolete: true
Attachment #8839376 - Attachment is obsolete: true
Attachment #8839377 - Attachment is obsolete: true
Attachment #8839378 - Attachment is obsolete: true
Attachment #8839379 - Attachment is obsolete: true
Flags: needinfo?(zoelskoeltem03_05_)
Status: UNCONFIRMED → NEW
Ever confirmed: true
When I removed "Firefox" entry from RegisteredApplications keys, Default apps started listing Nightly. Apparently, if multiple RegisteredApplications entries refer the same app, Windows will confuse and remove both entries from the Default apps list. We should make sure to undupe entries.
STR without manipulating registry:
1. Install the latest Nightly.
2. Install Nightly Feb 01 build <https://ftp.mozilla.org/pub/firefox/nightly/2017/02/2017-02-01-03-02-07-mozilla-central/> or earlier over.

Once the problem happens, overwrite install does not fix the issue. Uninstall & reinstall fixed the problem for me.

We should check duplicate RegisteredApplications entries and remove it if found. Matt, could you take a look?
Flags: needinfo?(mhowell)
I think those STR are a pretty unusual thing to do (installing an older build over a current one, I mean), so I don't mind the fact that an uninstall is necessary to fix that situation.

But, I do agree that more robustness is called for. I'll put a patch together that goes a bit farther to prevent duplicate entries from being created.
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Flags: needinfo?(mhowell)
Component: Shell Integration → Installer
Comment on attachment 8840981 [details]
Bug 1340568 - Fix some cases of the installer generating duplicate registry keys.

https://reviewboard.mozilla.org/r/115358/#review117530

Looks good though I'm somewhat concerned about additional issues. Might be a good thing to have QA test this out thoroughly.
Attachment #8840981 - Flags: review?(robert.strong.bugs) → review+
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3395a077e804
Fix some cases of the installer generating duplicate registry keys. r=rstrong
https://hg.mozilla.org/mozilla-central/rev/3395a077e804
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
The bug has been verified [bugday 20170308]
Operating System:win 10 64 bit
Firefox version:54.0

This bug can be reproduced in my Firefox version.This bug should should be resolved and fixed.

BUGDAY [1340568]
(In reply to roshini from comment #29)
> Operating System:win 10 64 bit
> Firefox version:54.0
> 
> This bug can be reproduced in my Firefox version.This bug should should be
> resolved and fixed.
> 
> BUGDAY [1340568]

Thanks for the report, but the issue you're seeing is probably not exactly this bug. Please file a new bug, and include more information about the exact steps you're following to get to the issue.
You need to log in before you can comment on or make changes to this bug.