Bug 1340591 (webext-port-s3download-statusbar)

WebExtensions-Port of s3download-statusbar

RESOLVED INVALID

Status

WebExtensions
Compatibility
P5
normal
RESOLVED INVALID
a year ago
a month ago

People

(Reporter: Stefano Caselli, Assigned: Oleksandr)

Tracking

(Depends on: 1 bug, {addon-compat})

53 Branch
addon-compat

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [triaged][awe:{s3download@statusbar}], URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

I hope the S3 Download status bar addon will be ported to WebExtensions.
(https://addons.mozilla.org/it/firefox/addon/s3download-statusbar)
This bug is to ask Mozilla to add necessary WE API to support this specific use case.
Thanks.

Updated

a year ago
Component: Downloads API → WebExtensions: Untriaged

Comment 1

a year ago
Are you the add-on author? We'd need some specific API requests to be able to proceed with this and looking at that add-on there are parts of that add-on that are not possible to do in WebExtensions.
Component: WebExtensions: Untriaged → WebExtensions: Compatibility
Priority: -- → P5
Summary: WebExtension API to support s3 download status bar → Allow s3 download status bar to be ported
Whiteboard: [triaged][awe:{s3download@statusbar}]
(Reporter)

Comment 3

a year ago
no, I'm not the author, but still I'd like to help.
I hope that at least the "core" of the addon can be supported: showing the downloads in a bar at the bottom of the screen (I really like the approach, since I can see all downloads progress while at the same time continuing browsing).
I already asked the author about the porting, and he was hoping to use the devtools panels api to create the download bar. is it possible?
thanks.
(Assignee)

Comment 4

a year ago
Hey, I'm author.
when it will be possible to create a custom bottom panel (as is statusbar, download bar, etc) in WebExtensions?

Comment 5

a year ago
There is no plan to be able to create a custom bottom panel at this time.

Updated

a year ago
Depends on: 1215064
Alias: webext-port-s3-download-status-bar
Blocks: 1280062
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Alias: webext-port-s3-download-status-bar → webext-port-s3download-statusbar
Assignee: nobody → pag77
Summary: Allow s3 download status bar to be ported → WebExtensions-Port of s3download-statusbar
No longer blocks: 1280062
Keywords: addon-compat
(Assignee)

Comment 6

5 months ago
browser.downloads.search - does not display history from past sessions
https://bugzilla.mozilla.org/show_bug.cgi?id=1438899

chrome.downloads.drag is not a function
https://bugzilla.mozilla.org/show_bug.cgi?id=1439211

chrome.downloads.onDeterminingFilename is not a function
https://bugzilla.mozilla.org/show_bug.cgi?id=1439992

WebExtensions: browser.downloads.open - not open from content script
https://bugzilla.mozilla.org/show_bug.cgi?id=1439165
(Assignee)

Comment 7

5 months ago
downloadItem.exists does not change from true to false when a file is removed
https://bugzilla.mozilla.org/show_bug.cgi?id=1381031
(Assignee)

Comment 8

5 months ago
browser.downloads.search - does not display history from past sessions
https://bugzilla.mozilla.org/show_bug.cgi?id=1255507

chrome.downloads.drag is not a function
https://bugzilla.mozilla.org/show_bug.cgi?id=1245648
(Assignee)

Comment 9

4 months ago
WebExtensions version:
https://addons.mozilla.org/addon/s3download-statusbar/
(Assignee)

Comment 10

4 months ago
"Bug" resolved - Please close this topic
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID

Updated

a month ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.