WebExtension: support title property for tabs.update

RESOLVED DUPLICATE of bug 1333943

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1333943
6 months ago
6 months ago

People

(Reporter: Geoffrey De Belie (Smile4ever), Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170215110151

Steps to reproduce:

The "title" property is not supported when updating a the properties of a tab. This is a request to make this possible without resorting to DOM manipulation.

(Please note this request is not the same as https://bugzilla.mozilla.org/show_bug.cgi?id=1333376)

browser.tabs.update(tab.id, {
	title: "+" + tab.title
}).then(
	function(data){
		console.log("Update OK");
	},
	function(error){
		console.log("Update failed: " + error);
	}
);


Actual results:

Error: Type error for parameter updateProperties (Unexpected property "title") for tabs.update.

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333943
You need to log in before you can comment on or make changes to this bug.