Blocked network requests are not displayed in the Network Monitor

RESOLVED DUPLICATE of bug 1273760

Status

()

Firefox
Developer Tools: Netmonitor
P3
normal
RESOLVED DUPLICATE of bug 1273760
11 months ago
10 months ago

People

(Reporter: unknown, Unassigned)

Tracking

(Blocks: 1 bug)

54 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: chrome-parity)

Attachments

(4 attachments)

(Reporter)

Description

11 months ago
Created attachment 8838949 [details]
network_monitor_chromium.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36 OPR/39.0.2256.43

Steps to reproduce:

Summary
-----------
I performed a simple test in both Firefox and Chromium to see how network requests blocked by uMatrix were displayed in the network monitor component of the developer tools of both browsers.

Browser and add-on information
------------------------------------
Firefox: Nightly 54.0a1 (2017-02-19) (64-bit)
Chromium: 56.0.2924.76 (64-bit)
uMatrix: 0.9.3.6 (my uMatrix configuration is to block everything by default)

Steps
-------
1. I launched Firefox and then opened the Network Monitor with the filter set to 'All'.
2. I then browsed to 'news.com.au' in Firefox and observed the output of the network monitor.
3. I performed the same steps in Chromium.


Actual results:

1. Firefox received a 301 redirect after loading 'news.com.au' and proceeded to load 'www.news.com.au'.
2. uMatrix in Firefox correctly blocked everything other than these two requests, see umatrix_firefox.png.
3. The Firefox network inspector displayed these two requests but not the requests that were blocked by uMatrix, see network_monitor_firefox.png
4. Chromium received a 301 redirect after loading 'news.com.au' and proceeded to load 'www.news.com.au'.
5. uMatrix in Chromium correctly blocked everything other than these two requests, see umatrix_chromium.png.
6. The Chromium network inspector displayed these two requests along with the requests blocked by uMatrix, see network_monitor_chromium.png. The blocked requests appeared in red and showed the error 'ERR_BLOCKED_BY_CLIENT'.


Expected results:

It would be very helpful if Firefox could display blocked network requests in its network monitor, in a similar fashion to Chromium.
(Reporter)

Updated

11 months ago
Component: Untriaged → Developer Tools: Netmonitor
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Whiteboard: chrome-parity
(Reporter)

Comment 1

11 months ago
Created attachment 8838950 [details]
network_monitor_firefox.png
(Reporter)

Comment 2

11 months ago
Created attachment 8838951 [details]
umatrix_chromium.png
(Reporter)

Comment 3

11 months ago
Created attachment 8838952 [details]
umatrix_firefox.png
Priority: -- → P3

Comment 4

10 months ago
I think this is duplicate of bug#1273760. It got implemented in Release 52
Thanks for the note, closing.
Honza
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273760
You need to log in before you can comment on or make changes to this bug.