popup.xml: menupopup is not defined in `mousemove` handler for popup-scrollbars

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
I'm working on enabling no-undef eslint rule for toolkit/ and I discovered this error:

/Users/mark/dev/gecko/toolkit/content/widgets/popup.xml
  725:10  error  'menupopup' is not defined.       no-undef (eslint)

This is in the `mousemove` handler for the popup-scrollbars.

It looks like the `menupopup.releaseCapture()` should be `this.releaseCapture()`.

I also wonder if this may have been part of the cause of the issues for bug 1332708.
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8839148 [details]
Bug 1341031 - Fix releasing drag capture for popups.

https://reviewboard.mozilla.org/r/113868/#review115606

Thanks! Glad to see these rules catching real bugs!
Attachment #8839148 - Flags: review?(mconley) → review+

Comment 3

2 years ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cec05d38d05
Fix releasing drag capture for popups. r=mconley

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2cec05d38d05
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.