Bookmark using a single hash character as keyword no longer works

RESOLVED DUPLICATE of bug 1334911

Status

()

RESOLVED DUPLICATE of bug 1334911
2 years ago
2 years ago

People

(Reporter: laszlok, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Create a bookmark with the keyword '#' (a single hash character) and containing a %s placeholder.
Type "# something" in the address bar. Hit Enter.


Actual results:

A web search for the typed phrase is carried out.


Expected results:

The address pointed to by the bookmark, with "something" substituted for "%s", should be opened.
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true

Comment 1

2 years ago
Character not allowed for keyword.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334911
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> Character not allowed for keyword.

What exactly do you mean by "not allowed"? It used to work fine up until version 50, and nowhere in the release notes or any other documentation can I find any reference to any character being disallowed.

I'm also not convinced this is a duplicate, since there does seem to be a reason to disallow the '*' character.

Comment 3

2 years ago
Please, read the duplicates. It was not supposed to work at all.
(Reporter)

Comment 4

2 years ago
(In reply to Loic from comment #3)
> Please, read the duplicates. It was not supposed to work at all.

I have read the duplicates, they weren't very helpful.

Googling further with the little info given for the '*' character, I've found this page:
https://support.mozilla.org/t5/Basic-Browsing/Awesome-Bar-Search-your-Firefox-bookmarks-history-and-tabs-from/ta-p/1485

where it says in section "Changing results on the fly" at the bottom that '#' (along with a number of other characters) is used to filter suggestions shown by the location bar. I presume that's why it doesn't work now?

Whether or not it was supposed to work, it did work for countless years, and apparently many users were relying on it. I'm not sold on the idea that it shouldn't work, it should be easy for the keyword to continue taking precedence. But if that's a final decision, then at the very least an exhaustive list of disallowed characters should be listed e.g. on this page:
https://support.mozilla.org/t5/Learn-the-Basics-get-started/How-to-search-IMDB-Wikipedia-and-more-from-the-address-bar/ta-p/380

(And ideally of course it should have been mentioned in the release notes.)

Updated

2 years ago
Flags: needinfo?(mak77)

Comment 5

2 years ago
Marco, if it's intended now, should we modify the FAQ?
(Reporter)

Comment 6

2 years ago
Note: I find that by changing the value for browser.urlbar.match.title in about:config the '#' keyword works again.
(In reply to Loic from comment #5)
> Marco, if it's intended now, should we modify the FAQ?

I don't think it's worth it:
1. keywords are a feature used by a tiny minority of users
2. out of them, it's likely that very few use special chars as keywords
I think those articles should report information that is relevant for the majority of users, or they'd soon become unmanageable and unreadable. Moreover making the thing exhaustive would be complex: there's a workaround, the user may have changed the restriction chars, and in the future we could change the way restriction characters work (there are various bugs on file). The article would be wrong again and again, not worth it.

(In reply to laszlok from comment #6)
> Note: I find that by changing the value for browser.urlbar.match.title in
> about:config the '#' keyword works again.

Yes, that's the suggested workaround, if you really need to use that specific keyword.
Flags: needinfo?(mak77)
You need to log in before you can comment on or make changes to this bug.