whitespace-only text node shows up as "o"

RESOLVED FIXED in Firefox 54

Status

()

Firefox
Developer Tools: Inspector
P3
enhancement
RESOLVED FIXED
3 months ago
12 days ago

People

(Reporter: Luke, Assigned: jdescottes)

Tracking

({dev-doc-complete})

52 Branch
Firefox 54
dev-doc-complete
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170220231536

Steps to reproduce:

Opened inspector on some html with enter between elements.


Actual results:

Whitespace-only text node shows up as "o" in the inspector... why? 


Expected results:

shouldn't show this bogus "o", I thought there was typo in output code.

Comment 1

3 months ago
Any testcase, please?
Component: Untriaged → Developer Tools: Inspector
Flags: needinfo?(lb1.3)

Comment 2

3 months ago
Created attachment 8839556 [details]
Screenshot
Flags: needinfo?(lb1.3)

Comment 3

3 months ago
Bug 1304685.


It should have some descriptive, such as tooltip.
Blocks: 1304685
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Summary: whitespace-only text node → whitespace-only text node shows up as "o"

Comment 4

3 months ago
Created attachment 8839565 [details]
whitespace.jpg

(In reply to YF (Yang) from comment #3)
> Bug 1304685.
> 
> 
> It should have some descriptive, such as tooltip.

It's already the case in Nightly, I don't think there is something to fix here. :)

Comment 5

3 months ago
(In reply to Loic from comment #4)
> Created attachment 8839565 [details]
> whitespace.jpg
> 
> (In reply to YF (Yang) from comment #3)
> > Bug 1304685.
> > 
> > 
> > It should have some descriptive, such as tooltip.
> 
> It's already the case in Nightly, I don't think there is something to fix
> here. :)

Looks good, but can be better if the tooltip hot area (trigger) is bigger.
Severity: normal → minor
(Assignee)

Comment 6

3 months ago
We display whitespace text nodes in the inspector if they have an impact on the layout. Such text nodes often create hard to understand layout issues (gaps between nodes etc...), and most inspectors don't let developers inspect them.

Now the representation can probably be improved to avoid the confusion with the letter "o". We discussed several proposals for the initial implementation in Bug 1304685. My initial idea was https://bug1304685.bmoattachments.org/attachment.cgi?id=8794103
I still like it, because it's hard to mistake it for another element (maybe the fading was too much).
(Assignee)

Comment 7

3 months ago
Patrick: what do you think about updating the representation here?
Severity: minor → enhancement
Flags: needinfo?(pbrosset)
Priority: -- → P3
(In reply to Julian Descottes [:jdescottes] from comment #7)
> Patrick: what do you think about updating the representation here?
Sure, I'm not against it, especially if the character we chose gets confused with the 'o' letter.
Attachment 8794103 [details] looks good to me especially because it looks exactly like the [...] icon we have in between an opening and closing tag when the element has child nodes. So I see the value of consistency here.
Flags: needinfo?(pbrosset)
(Assignee)

Comment 9

3 months ago
Created attachment 8841514 [details] [diff] [review]
Bug 1341258 - update display of whitespace nodes in markup view;r=gl
Attachment #8841514 - Flags: review?(gl)

Updated

3 months ago
Attachment #8841514 - Flags: review?(gl) → review+
(Assignee)

Updated

3 months ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Keywords: checkin-needed

Comment 10

3 months ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6bf5cd5c076b
update display of whitespace nodes in markup view;r=gl
Keywords: checkin-needed

Comment 11

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6bf5cd5c076b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Keywords: dev-doc-needed
I have reproduced this bug with Nightly 54.0a1 (2017-02-21) (64-bit) on Manjaro Linux 17!

This bug's fix is verified with latest Beta!

Build ID 	20170511200247
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0

[testday-20170512]

Updated

12 days ago
Keywords: dev-doc-needed → dev-doc-complete

Comment 13

12 days ago
Docs update here: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Examine_and_edit_HTML
You need to log in before you can comment on or make changes to this bug.