XMLHttpRequest text decoding does not BOM sniff appropriately

RESOLVED DUPLICATE of bug 1070763

Status

()

Core
DOM
P2
normal
RESOLVED DUPLICATE of bug 1070763
a year ago
a year ago

People

(Reporter: annevk, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
See https://github.com/w3c/web-platform-tests/pull/4935. It seems like we ignore UTF-16 BOMs for text/plain and decode as UTF-8 instead. That's wrong.

The EOF issue decoders also bites us here.
(Reporter)

Comment 1

a year ago
XMLHttpRequest/send-receive-utf16.htm might also be affected.
Henri, is this something you could take?
Flags: needinfo?(hsivonen)
Priority: -- → P2
Duplicate of bug 1070763. Waiting for encoding_rs to land, because this would be annoying to fix without the facilities provided by encoding_rs (in particular, streaming BOM sniffing baked into the decoders themselves).
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(hsivonen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1070763
You need to log in before you can comment on or make changes to this bug.