Closed Bug 1341353 Opened 3 years ago Closed 3 years ago

Webcompat reporter crashes nightly on some sites with ipc.processCount > 1

Categories

(Web Compatibility :: Tooling & Investigations, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1340921

People

(Reporter: adamopenweb, Unassigned)

References

()

Details

Testing with Nightly 54.0a1 (2017-02-21) on OSX 10.11.6.

STR:
1. Launch Nightly 54.0
2. Ensure ipc.processCount is set > 1
3. Navigate to: https://www.just-eat.ca/restaurants-shanghai-chinese-food/menu
4. Click the Firefox menu then Report site issue

Expected Behavior:
New tab opens on webcompat.com, with screenshot of tab

Actual Behavior:
New tab opens, page starts to load, then browser crashes

I found that https://miketaylr.com/ also causes the crash.

Mozregression pointed to bug 1303113.

Crash report: https://crash-stats.mozilla.com/report/index/95a098f6-fd43-4ad7-8dd1-96aad2170221
This was tested on a Macbook Pro (15-inch, Mid 2015 w/AMD Radeon R9 M370X).

When testing on an old iMac running OSX 10.9.5, I can't reproduce the crash on justeat.ca but I can on miketaylr.com. But if I change ipc.processCount to 1, there is no crash.
Adding the crash signature so this gets picked up in a query - this product doesn't seem to have a crash stats field: [@ <name omitted> | mozilla::dom::BlobParent::RecvPBlobStreamConstructor ]
Marking as a dupe of Bug 1340921 to make it easier to track - and there is also a needinfo in that bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1340921
You need to log in before you can comment on or make changes to this bug.