Closed Bug 1341420 Opened 5 years ago Closed 5 years ago

Stop loading devtools/client/webconsole/net/main

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1326937

People

(Reporter: ntim, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I'm not 100% sure this is worth doing, considering that we hope to remove the old console
and that console.time/timeEnd logging shows that this file's load takes ~50ms.
However, I did it anyway to try to learn something about the console.
Assignee: nobody → ttromey
Comment on attachment 8851046 [details]
Bug 1341420 - don't load main.js from webconsole.xul;

https://reviewboard.mozilla.org/r/123490/#review126206

This looks good for me. Let's see what TRY thinks about it
Looks like TRY isn't happy with the patch : https://treeherder.mozilla.org/#/jobs?repo=try&revision=94d83cd6eb5131bca45bc756e1669da2528ca0ca
Mainly, it seems to causes issues with network messages.
Comment on attachment 8851046 [details]
Bug 1341420 - don't load main.js from webconsole.xul;

https://reviewboard.mozilla.org/r/123492/#review130822

r- since TRY is failing
Attachment #8851046 - Flags: review?(nchevobbe) → review-
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [reserve-new-console]
Whiteboard: [reserve-new-console] → [reserve-console-html]
Flags: qe-verify? → qe-verify-
When loading in an HTML frame for the new console (Bug 1326937) we won't need to include this script since the new frontend doesn't use xhrspy (Bug 1362036 is opened to use some sort of shared component for requests with the netmonitor).  So going to dupe to Bug 1326937.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1326937
Assignee: ttromey → nobody
No longer blocks: enable-new-console
Flags: qe-verify-
Priority: P3 → --
Whiteboard: [reserve-console-html]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.