Closed Bug 134145 Opened 22 years ago Closed 22 years ago

New name server not taken into account

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 64857

People

(Reporter: laurent, Unassigned)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031008

I use Mozilla 0.9.9 on my laptop and I move from one network to another several
times a day. As I move from network to network my DHCP client updates my IP
address but it also upates the nameserver IP address in /etc/resolv.conf.

When the nameserver changes Mozilla stops working. For Mozilla to work again I
must stop and start it again and then it takes the new nameserver into account.

Isn't there a way for Mozilla to monitor the changes in the /etc/resolv.conf
file. It's really an annoying bug because Each time I restart Mozilla I loose
all my working context.


Reproducible: Always
Steps to Reproduce:
1.Plug laptop to network - obtain nameserver with DHCP
2.Start Mozilla - Work with it
3.Suspend the laptop
4.Move to another network
5.Wake-up the laptop and the DHCP client get a new IP address and a new
nameserver address
6. If you try and access a site with Mozilla it takes forever because it still
tries to access the old nameserver.


Actual Results:  Mozilla not usable. Can't browse the Web anymore

Expected Results:  Talk to the new nameserver and let me access the Web

I think an acceptable workaround would be to cycle through the offline-online
icon and say that when Mozilla goes online again it takes a look at the current
DNS server.
Can confirm this bug. This is very annoying if you have to switch your
nameserver often. Most other apps I know have no problem with this.

Should I change the status to new if I can confirm such a bug and don't find any
duplicates?
I guess this is not my decision to change the status to New. One thing I can say
though is that it's a typical bug where Severity is not that high (it is
currently to Normal) but Priority should be very high because it is actually
*very* annoying and the usability of Mozilla for mobile workers is severely
impacted.

My $.01 contribution

*** This bug has been marked as a duplicate of 64857 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.