All users were logged out of Bugzilla on October 13th, 2018

signaling fuzztest should be linked with mozglue

RESOLVED DUPLICATE of bug 1340760

Status

()

RESOLVED DUPLICATE of bug 1340760
2 years ago
2 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Today when I updated my source tree I got this build failure:

 2:25.75 Executing: /usr/local/bin/ccache /Users/ehsan/Downloads/clang+llvm-3.9.0-x86_64-apple-darwin/bin/clang++ -std=gnu++11 -o sdp_file_parser -Qunused-arguments -Qunused-arguments -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++11-compat-pedantic -Wc++14-compat -Wc++14-compat-pedantic -Wc++1z-compat -Wimplicit-fallthrough -Wstring-conversion -Wthread-safety -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wno-unknown-warning-option -Wno-return-type-c-linkage -fcolor-diagnostics -fno-exceptions -fno-strict-aliasing -stdlib=libc++ -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang ../../../../build/clang-plugin/libclang-plugin.dylib -Xclang -add-plugin -Xclang moz-check -fno-omit-frame-pointer -Wl,-filelist,/Users/ehsan/moz/src/obj-ff-clang-plugin.noindex/media/webrtc/signaling/fuzztest/tmpY6V3v_.list -framework Cocoa -lobjc -framework AudioToolbox -framework ExceptionHandling -Wl,-executable_path,/Users/ehsan/moz/src/obj-ff-clang-plugin.noindex/dist/bin ../../../../security/libnss3.dylib
 2:25.78 /Users/ehsan/moz/src/obj-ff-clang-plugin.noindex/media/webrtc/signaling/fuzztest/tmpY6V3v_.list:
 2:25.78     cpr_string.o
 2:25.78     sdp_access.o
 2:25.78     sdp_attr.o
 2:25.78     sdp_attr_access.o
 2:25.78     sdp_base64.o
 2:25.79     sdp_config.o
 2:25.79     sdp_main.o
 2:25.79     sdp_services_unix.o
 2:25.79     sdp_token.o
 2:25.79     sdp_utils.o
 2:25.79     sdp_file_parser.o
 2:25.79     SdpAttribute.o
 2:25.79     SdpHelper.o
 2:25.79     SdpMediaSection.o
 2:25.79     SipccSdp.o
 2:25.79     SipccSdpAttributeList.o
 2:25.79     SipccSdpMediaSection.o
 2:25.84     SipccSdpParser.o
 2:25.84     ../../trunk/testing/gtest_gtest/Unified_cpp_trunk_testing0.o
 2:25.84     ../../trunk/testing/gtest_gtest/Unified_mm_trunk_testing0.o
 2:25.84
 2:25.84 Undefined symbols for architecture x86_64:
 2:25.84   "mozilla::PrintfTarget::vprint(char const*, __va_list_tag*)", referenced from:
 2:25.84       char* mozilla::Smprintf<mozilla::MallocAllocPolicy>(char const*, ...) in SdpHelper.o
 2:25.84 ld: symbol(s) not found for architecture x86_64
 2:25.84 clang-3.9: error: linker command failed with exit code 1 (use -v to see invocation)
 2:25.84 make[5]: *** [sdp_file_parser] Error 1
 2:25.84 make[4]: *** [media/webrtc/signaling/fuzztest/target] Error 2
 2:25.93 make[4]: *** Waiting for unfinished jobs....

This is coming from the NS_ENSURE_SUCCESS macros in SdpHelper.cpp, which refer to code that is implemented in an mfbt cpp file, so we should link against mozglue.
(Reporter)

Comment 1

2 years ago
Created attachment 8839785 [details] [diff] [review]
Link signaling fuzztest agianst mfbt
Attachment #8839785 - Flags: review?(rjesup)

Updated

2 years ago
Attachment #8839785 - Flags: review?(rjesup) → review+
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1340760
You need to log in before you can comment on or make changes to this bug.