Closed Bug 1341728 Opened 3 years ago Closed 3 years ago

stylo: Need to support the "clip" property

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox54 --- affected

People

(Reporter: bzbarsky, Assigned: canova)

References

(Blocks 1 open bug)

Details

Simple testcase:

  data:text/html,<div style="clip: rect(0, 0, 0, 0)"><script>alert(document.querySelector("div").style.clip);</script>

This does not work right.  I'm not sure whether the problem is in servo or the glue code.
I can work on the glue part.
(In reply to Nazım Can Altınova [:canaltinova] from comment #2)
> I can work on the glue part.

Awesome, thanks!
Opened a PR in servo: https://github.com/servo/servo/pull/15710
Assignee: nobody → canaltinova
PR is merged. Clip property should work now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1ac7cfa737c
test expectation adjustments, since servo now supports clip.  r=bzbarsky
Yay, passing tests.  Thank you!
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6cea4e8a9158
more test expectation adjustments, for mochitests now.  r=bzbarsky
You need to log in before you can comment on or make changes to this bug.