stylo: need support for -moz-transform-* properties

RESOLVED DUPLICATE of bug 1351356

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED DUPLICATE of bug 1351356
4 months ago
3 months ago

People

(Reporter: bz, Assigned: cjku)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(1 attachment)

And generally all the -moz properties...
Flags: needinfo?(simon.sapin)
Note that stylo apparently supports "-moz-transform-origin" but not "-moz-transform"?
Priority: -- → P2
This is probably another good one for CJ.
Flags: needinfo?(simon.sapin)
Priority: P2 → P1
Assignee: nobody → cku
(Assignee)

Comment 3

3 months ago
I will work on this from next week.
(Assignee)

Comment 4

3 months ago
Created attachment 8850432 [details]
-moz-transform test case
(Assignee)

Comment 5

3 months ago
hmm, generally, all -moz prop is not work.
Since webkit prefix works correctly, I will look around to see how it works.
If you look in servo/components/style/properties/longhand/box.mako.rs you have lines like this:

  <%helpers:longhand name="transform-origin" animatable="True" extra_prefixes="moz webkit" boxed="True"

vs

  <%helpers:longhand name="transform" products="gecko servo" extra_prefixes="webkit"

note the extra_prefixes bits.

Looks to me like "transform-style" does the right thing already.  Anyway, the point is we should go through layout/style/nsCSSPropAliasList.h and check that all those do the right thing.

The -moz-transform case is harder because it is NOT an alias.  See the aDisallowRelativeValues argument to ParseTransform in Gecko.  It's false for "transform" but true for "-moz-transform".  I think the main impact is that percentage values are not allowed in -moz-transform?  Needs checking.
Nazim is going to work on this in bug 1351356.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1351356
You need to log in before you can comment on or make changes to this bug.