Grid Inspector disappears changing the height of developer toggle tools inside Fx

RESOLVED DUPLICATE of bug 1343879

Status

DevTools
Inspector
P3
normal
RESOLVED DUPLICATE of bug 1343879
a year ago
a month ago

People

(Reporter: bogdan_maris, Assigned: jdescottes)

Tracking

(Blocks: 3 bugs)

54 Branch
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 unaffected, firefox54 affected)

Details

Attachments

(1 obsolete attachment)

Created attachment 8840405 [details]
Grid website in Iframe

[Affected versions]:
- latest Nightly 54.0a1

[Affected platforms]:
- Windows 10 64-bit
- macOS 10.12.3
- Ubuntu 16.04 32-bit

[Steps to reproduce]:
1. Start Firefox
2. Download the attachment
3 [review]. Open inspector inside Firefox and activate Grid tool.
4. Change the height of Dev toggle tools

[Expected result]:
- Grid highlighter is not affected while Dev toggle tools is changed.

[Actual result]:
- Grid highlighter disappears when resizing Dev toggle tools

[Regression range]:
- This is a recent regression. Here is the mozregression output:

m-c:

Last good revision: 6cefe01ca7744d6ac3960c69eac833e2e65f7f8f (2017-02-17)
First bad revision: d11c29c1db3a1bc96ad5792ebf8a89b2fbadcf85 (2017-02-18)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cefe01ca7744d6ac3960c69eac833e2e65f7f8f&tochange=d11c29c1db3a1bc96ad5792ebf8a89b2fbadcf85

m-i:
Last good revision: 6cefe01ca7744d6ac3960c69eac833e2e65f7f8f
First bad revision: 975ce5d8f7d818cc3cd32b134e4010577d3208cd
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cefe01ca7744d6ac3960c69eac833e2e65f7f8f&tochange=975ce5d8f7d818cc3cd32b134e4010577d3208cd

- Not sure if the regression from inbound is correct, I ran into some build errors there, the m-c regression should have the culprit even though I can't exactly point out the bug that caused this.

[Additional notes]:
- Screencast showing the issue: https://dl.dropboxusercontent.com/u/109148197/CSS%20Grid%20Inspector/Devtools%20grid%20missing.gif
Comment on attachment 8840405 [details]
Grid website in Iframe

This attachment is not necessary to reproduce.

At step 2. one can only visit website: http://labs.jensimmons.com/examples/grid-content-1.html and follow the rest of the steps.
Attachment #8840405 - Attachment is obsolete: true
Blocks: 1181227
Flags: qe-verify+
Priority: -- → P3
Blocks: 1333358
Summary: Grid highlighter disappears changing the height of developer toggle tools inside Fx → Grid Inspector disappears changing the height of developer toggle tools inside Fx
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
It looks like the regression has been fixed in the latest Nightly ...

The "fix" range I got from mozregression is https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5dc5249408ecc0003f0c68d32a8e782dec23fd36&tochange=becff35a0bed14b536bb0a141b0e9640e9cb063d

I'm trying to identify the precise changeset that fixed the issue so that we can check if something needs to be uplifted to 54.
The issue was fixed by Bug 1343078, which is in Firefox 55.

Now that we know the "fixing" bug, we should find out the regressing bug and decide what is our best strategy to uplift a fix to 54.

For information, artifact builds have to be turned off when identifying regression windows for this issue.
Let's start by looking at https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cefe01ca7744d6ac3960c69eac833e2e65f7f8f&tochange=975ce5d8f7d818cc3cd32b134e4010577d3208cd
See Also: → bug 1343078
I am 95% certain that this is a regression from bug 1331322.  Specifically, that created a situation in which anonymous content added to the document could get reframed, which might affect the grid highligter, right?

The patch for bug 1343078 made this situation go away.  But the fix for bug 1343879 should also make it go away, and we are planning to backport it to aurora.  There's a pretty good chance that will fix this bug too.
Blocks: 1331322
Depends on: 1343879
Yep, verified via local test on aurora that the patch for bug 1343879 fixes this bug there.
Thank you so much for looking into this Boris! 

Let's dupe this on Bug 1343879.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1343879

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.