Closed Bug 1342085 Opened 5 years ago Closed 1 year ago

Outdated description of NSS_BUILTINS_LIBRARY_VERSION

Categories

(NSS :: CA Certificates Code, task)

3.29
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: szidek, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160406092330

Steps to reproduce:

Line 21 and following in nss-3.29.1/nss/lib/ckfw/builtins/nssckbi.h state that NSS_BUILTINS_LIBRARY_VERSION_MINOR numbers are allocated for particular branches.


Actual results:

According to the description, 3.29 branch should have numbers 240-249. However, it is not true:
#define NSS_BUILTINS_LIBRARY_VERSION_MINOR 11



Expected results:

I suppose the comment should be updated when convenient.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for reminding me to update the comment.

This triggered me to think about new rules.

 /* These version numbers detail the changes
  * to the list of trusted certificates.
  *
  * The NSS_BUILTINS_LIBRARY_VERSION_MINOR macro needs to be bumped
- * for each NSS minor release AND whenever we change the list of
- * trusted certificates.  10 minor versions are allocated for each
- * NSS 3.x branch as follows, allowing us to change the list of
- * trusted certificates up to 9 times on each branch.
- *   - NSS 3.5 branch:  3-9
- *   - NSS 3.6 branch:  10-19
- *   - NSS 3.7 branch:  20-29
- *   - NSS 3.8 branch:  30-39
- *   - NSS 3.9 branch:  40-49
- *   - NSS 3.10 branch: 50-59
- *   - NSS 3.11 branch: 60-69
- *     ...
- *   - NSS 3.12 branch: 70-89
- *   - NSS 3.13 branch: 90-99
- *   - NSS 3.14 branch: 100-109
- *     ...
- *   - NSS 3.29 branch: 250-255
+ * whenever we change the list of trusted certificates.
+ *
+ * Please use the following rules when increasing the version number:
+ *
+ * - starting with version 2.14, NSS_BUILTINS_LIBRARY_VERSION_MINOR
+ *   must always be an EVEN number (e.g. 16, 18, 20 etc.)
+ *
+ * - whenever possible, older branches that require a modification to the
+ *   list, these changes be made on the main line of development (trunk),
+ *   and the older branch should update to the most recent list.
+ * 
+ * - ODD minor version numbers are reserved to indicate a snapshot that has
+ *   deviated from the main line of development, e.g. if it was necessary
+ *   to modify the list on a stable branch.
+ *   Once the version has been changed to an odd number (e.g. 2.13), it should
+ *   remain unchanged on that branch, even if further changes are made
+ *   on that branch.
  *
  * NSS_BUILTINS_LIBRARY_VERSION_MINOR is a CK_BYTE.  It's not clear
  * whether we may use its full range (0-255) or only 0-99 because
  * of the comment in the CK_VERSION type definition.
+ * It's recommend to switch back to 0 after having reached version 98/99.
  */

I intend to land this change as part of bug 1350859, unless more discussion is needed.
Depends on: 1350859

This was fixed in the mentioned bug, so I think this can be closed.

Flags: needinfo?(jjones)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jjones)
QA Contact: jjones
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.