Closed Bug 1342316 Opened 4 years ago Closed 3 years ago

stylo: Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at nsCSSValue.cpp:873

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- disabled
firefox55 --- fixed

People

(Reporter: cbook, Assigned: hiro)

References

()

Details

(Keywords: assertion, regression)

Attachments

(4 files)

Attached file bughunter stack
found via topsite bughunter tests on http://www.disqus.com and reproduced with latest stylo-debug build from taskcluster

Steps to reproduce:
-> Load http://www.disqus.com
---> Assertion failure after ~ 5 to 10 seconds on my fedora vm

Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at /home/worker/workspace/build/src/layout/style/nsCSSValue.cpp:873
note, this seem to happen on a lot of urls according to bughunter
This is animation bug.
Component: Layout → CSS Parsing and Computation
Summary: Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at nsCSSValue.cpp:873 → [stylo] Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at nsCSSValue.cpp:873
Leaving ni to me.
Bug 1341985 or bug 1340322 fixes this.  I will check this again after those of bugs are closed.
Flags: needinfo?(hikezoe)
Bug 1341985 fixed this.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(hikezoe)
Resolution: --- → FIXED
seems this is not fixed, bughunter run into the same assertion again with todays build.

Its a stylo bug i guess because on win 7 i didn't crash but with the lastest stylo build from taskcluster i did.

Steps to reproduce:
Load http://www.wheelcovers.com 
wait for 10-30 seconds

--> Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at /home/worker/workspace/build/src/layout/style/nsCSSValue.cpp:880
Status: RESOLVED → REOPENED
Flags: needinfo?(hikezoe)
Resolution: FIXED → ---
Attached file new bughunter stack
Summary: [stylo] Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at nsCSSValue.cpp:873 → stylo: Assertion failure: array->Count() == 2 (eCSSUnit_Calc_Plus should have a 2-length array), at nsCSSValue.cpp:873
No longer blocks: stylo-nightly
Hiro, looks like this assertion failure was not fixed by bug 1341985 or bug 1340322.
Assignee: nobody → hikezoe
Priority: -- → P2
I will look into this after I fixed bug 1354947.
Comment on attachment 8862659 [details]
Bug 1342316 - Check eCSSUnit_Calc_Plus' array length in assertion.

https://reviewboard.mozilla.org/r/134524/#review137866
Attachment #8862659 - Flags: review?(cam) → review+
Comment on attachment 8862660 [details]
Bug 1342316 - A crashtest which has calc() method in translate3d function as base style of transform animation.

https://reviewboard.mozilla.org/r/134526/#review137870
Attachment #8862660 - Flags: review?(cam) → review+
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cf0ebc74751
Check eCSSUnit_Calc_Plus' array length in assertion. r=heycam
https://hg.mozilla.org/integration/autoland/rev/24032eef27b3
A crashtest which has calc() method in translate3d function as base style of transform animation. r=heycam
Thank you!
https://hg.mozilla.org/mozilla-central/rev/2cf0ebc74751
https://hg.mozilla.org/mozilla-central/rev/24032eef27b3
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.