Closed Bug 1342334 Opened 5 years ago Closed 5 years ago

Intermittent jetpack-package/addon-sdk/source/test/test-tabs.js.testBug682681_aboutURI | Test timed out (after: START)

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

(In reply to Joel Maher ( :jmaher) from comment #2)
> I narrowed this down:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-
> searchStr=jetpack%20linux%20asan&tochange=5b49024a794b6e3148fa6aa1d92101f9e0f
> 37015&fromchange=c8b32cb1f15b5ad2588ddde5a3127697537b965a
> 
> :ehsan, I see you authored the two patches in:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=9fe977a59fa1656a0a03b8ea1ad6c873520ef1d2&filter-
> searchStr=jetpack%20linux%20asan

Hmm...

https://hg.mozilla.org/integration/mozilla-inbound/rev/ef1063db138cfbb3e6bb1f01d1e5e27947e53e94 is DEBUG only, so this can't be the culprit.

https://hg.mozilla.org/integration/mozilla-inbound/rev/9fe977a59fa1656a0a03b8ea1ad6c873520ef1d2, I'm not sure what to think about this one.  I can't come up with any theories, it looks trivially correct to me.  But perhaps my eyes are just glancing over something somewhere?

> this is when this failure started, can you take a look at this and get this
> fixed?

Andrew, can you please see if someone can help with this?  Sorry to keep bouncing bugs like this but I'm really swamped these days.  :(

Thanks Joel for tracking this down!
Flags: needinfo?(ehsan) → needinfo?(overholt)
baku said he'd take a look (he did review the work in bug 1341898)
Flags: needinfo?(overholt) → needinfo?(amarchesini)
this is >75 times/week, I would like to disable this test this week unless we have a specific fix for either the root cause or the test case.

:baku any updates?
odd, this was fixed last week, I cannot see indication this was disabled.
Whiteboard: [stockwell needswork] → [stockwell unknown]
Is this bug fixed? It seems we don't any any additional reports.
Flags: needinfo?(amarchesini) → needinfo?(jmaher)
yeah, 2+ months with no failures, anything new would be a new issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jmaher)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.