Background color not rendered on COL or COLGROUP elements

VERIFIED DUPLICATE of bug 4510

Status

()

P2
major
VERIFIED DUPLICATE of bug 4510
17 years ago
17 years ago

People

(Reporter: chrispetersen, Assigned: karnaze)

Tracking

({regression, topembed})

Trunk
regression, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Updated

17 years ago
Keywords: regression, xhtml
(Reporter)

Comment 1

17 years ago
This regression occured on the Feb 21 builds (2002-02-21-03). The previous build
(2002-02-20-16) rendered the page with assigned lime background color.
(Reporter)

Comment 2

17 years ago
Adding topembed. Occurs on the mfcembed March 27 0.9.9 build.
Severity: normal → major
Keywords: topembed
Priority: -- → P2
The most likely candidate seems to be bernd.mielke@snafu.de checkin to bug 4510.
Actually the patch was made by fantasai.

As you can see from the attached testcase this is not XHTML specific; HTML
regressed as well. Reassigning to HTML Tables.

Nominating for nsbeta1.
Assignee: heikki → karnaze
Component: XML → HTMLTables
Keywords: xhtml → nsbeta1
QA Contact: petersen → amar

Comment 6

17 years ago
its a dupe of 4510

*** This bug has been marked as a duplicate of 4510 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
How can this be dupe if this appeared when the patch in bug 4510 was checked in?

Comment 8

17 years ago
very easily, if the remaining issue in bug 4510 is column background
(Reporter)

Comment 9

17 years ago
I think this regression affects xhtml documents and html documents rendered in
standards mode. I couldn't get the background color to appear in quirks mode.
(Reporter)

Comment 10

17 years ago
My point is this was working with the test cases provided.
Then, the regression occured in the Feb 21 build.

Comment 11

17 years ago
Heikki -- The patch checked in for 4510 was a temporary fix; the bug's still 
open for having CSS2 compliant background rendering in Standard mode. (The patch 
reverted Standard mode to using Quirks rendering.)

The reason we took out the Standard mode rendering is because it was incorrect 
per CSS2, and if we're going to be incorrect, we might as well be consistent 
with MSIE and other incorrect browsers.
 Verified dupe of Bug # 4510
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.