Closed Bug 1342721 Opened 5 years ago Closed 5 years ago

Ensure that SpiderMonkey recursion checks are all inlines

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1342439

People

(Reporter: ehsan.akhgari, Assigned: ehsan.akhgari)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The recursion check macros are commonly used inside SpiderMonkey but
only in a few places in Gecko.  There’s currently an out-of-line call to
js::RunningWithTrustedPrincipals (a friend API unused in Gecko) which we
can eliminate by moving the macros inline inside SpiderMonkey and expose
APIs for the few Gecko consumers mentioned above.
The recursion check macros are commonly used inside SpiderMonkey but
only in a few places in Gecko.  There's currently an out-of-line call to
js::RunningWithTrustedPrincipals (a friend API unused in Gecko) which we
can eliminate by moving the macros inline inside SpiderMonkey and expose
APIs for the few Gecko consumers mentioned above.
Attachment #8841287 - Flags: review?(sphink)
Assignee: nobody → ehsan
Blocks: 1342713
Does bug 1342439 conflict with this?
(In reply to Emanuel Hoogeveen [:ehoogeveen] from comment #2)
> Does bug 1342439 conflict with this?

Sigh, almost certainly.  :(
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1342439
Attachment #8841287 - Flags: review?(sphink)
You need to log in before you can comment on or make changes to this bug.