Closed Bug 1342752 Opened 3 years ago Closed 3 years ago

Disable TLS 1.3 for SeaMonkey 2.48 and 2.49 release.

Categories

(SeaMonkey :: Preferences, defect)

SeaMonkey 2.48 Branch
defect
Not set

Tracking

(seamonkey2.48 fixed, seamonkey2.49esr fixed, seamonkey2.50 unaffected, seamonkey2.51 unaffected)

RESOLVED FIXED
seamonkey2.49
Tracking Status
seamonkey2.48 --- fixed
seamonkey2.49esr --- fixed
seamonkey2.50 --- unaffected
seamonkey2.51 --- unaffected

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1267631 +++

TLS 1.3 has been backed out from Firefox 52 in Bug 1342082. The ability to set it needs to be removed from SeaMonkey 2.48 and 2.49 too.
This patch if for comm-release and comm-beta (including 2.48b1 branch) only.

[Approval Request Comment]
Regression caused by (bug #): 1342752
User impact if declined: A wrong TLS setting will be shown in the preferences if the user selects TLS 1.3
Testing completed (on m-c, etc.): c-b
Risk to taking this patch (and alternatives if risky): none 
String changes made by this patch: none
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8841314 - Flags: review?(iann_bugzilla)
Attachment #8841314 - Flags: approval-comm-release?
Attachment #8841314 - Flags: approval-comm-beta?
Comment on attachment 8841314 [details] [diff] [review]
1342752-disabletls13.patch

LGTM r/a=me for c-b and c-r
Attachment #8841314 - Flags: review?(iann_bugzilla)
Attachment #8841314 - Flags: review+
Attachment #8841314 - Flags: approval-comm-release?
Attachment #8841314 - Flags: approval-comm-release+
Attachment #8841314 - Flags: approval-comm-beta?
Attachment #8841314 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.