Deadlock caused by TaskTracer

RESOLVED FIXED in Firefox 54

Status

()

defect
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sinker, Assigned: sinker)

Tracking

Trunk
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

2 years ago
Firefox is blocked with the log

 ###!!! ERROR: Potential deadlock detected

The backtrace of the main thread of the chrome process is as following lines

#2  0x00007ffff64cbb52 in PR_Lock (lock=0x7ffff6bac920)
    at /home/thinker/progm/mozilla-central/nsprpub/pr/src/pthreads/ptsynch.c:177
#3  0x00007fffe79eb86f in mozilla::OffTheBooksMutex::Lock() (this=0x7ffff6b1a4e0)   
    at /home/thinker/progm/mozilla-central/xpcom/threads/BlockingResourceBase.cpp:382
#4  0x00007fffe9ef4441 in profiler_start(int, double, char const**, unsigned int, char const**, unsigned int) (aEntries=10000000, aInterval=1, aFeatures=0x7fffb710e490, aFeatureCount=6, aThreadNameFilters=0x7fffb7abda90, aFilterCount=<optimized out>)
    at /home/thinker/progm/mozilla-central/tools/profiler/core/platform.cpp:1992
#5  0x00007fffe9ef4a7a in nsProfiler::StartProfiler(unsigned int, double, char const**, unsigned int, char const**, unsigned int) (this=<optimized out>, aEntries=<optimized out>, aInterval=<optimized out>, aFeatures=<optimized out>, aFeatureCount=<optimized out>, aThreadNameFilters=<optimized out>, aFilterCount=<optimized out>)
    at /home/thinker/progm/mozilla-central/tools/profiler/gecko/nsProfiler.cpp:92
#6  0x00007fffe79fe776 in NS_InvokeByIndex ()
    at /home/thinker/progm/mozilla-central/xpcom/reflect/xptcall/md/unix/xptcinvoke_asm_x86_64_unix.S:88
Assignee

Comment 1

2 years ago
There is a deadlock in |TracedTaskCommon::Init()|.
Attachment #8841413 - Flags: review?(cyu)
Assignee

Updated

2 years ago
Summary: Deadlock during starting profiler → Deadlock caused by TaskTracer
Attachment #8841413 - Flags: review?(cyu) → review+
Assignee

Comment 2

2 years ago
r=cervantes
Attachment #8841413 - Attachment is obsolete: true
Attachment #8842338 - Flags: review+
Assignee

Updated

2 years ago
Keywords: checkin-needed
Assignee: nobody → tlee

Comment 3

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/acf42887c8a7
Fix the deadlock caused by TaskTracer. r=cervantes
Keywords: checkin-needed

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/acf42887c8a7
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.