Web Extension API doesn't provide access to mouse events on tab container

RESOLVED DUPLICATE of bug 1246706

Status

RESOLVED DUPLICATE of bug 1246706
2 years ago
4 months ago

People

(Reporter: matthamilton, Unassigned)

Tracking

54 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170216004023

Steps to reproduce:

Hi, I am the maintainer of the following Firefox extension: https://github.com/mthamil/Tab-Wheel-Scroll.

It requires the ability to listen to mouse scroll events on the tab bar. I know some other larger addons provide similar functionality. I have reviewed the currently available web extension APIs as well as those on the roadmap, and I don't see anything that would fit my needs. Is this something that would be considered?
(Reporter)

Updated

2 years ago
Summary: Web Extension API doesn't provide access to mouse events on tab container. → Web Extension API doesn't provide access to mouse events on tab container

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246706

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.