Crash in libc-2.23.so@0x9889d

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: z.vanya, Unassigned)

Tracking

51 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-d5974174-a6fc-46d5-b913-b3b3e2170227.
=============================================================

I've been having this problem with ALT's build of firefox: firefox-esr-45.7.0-alt0.M70P.1 and 51.0.1-alt2 .

Now also with vanilla firefox 51.0.1 .

The --sync and --safe-mode don't make it go away.

If I open this URL under a fresh user, the crash is not reproduced. So, it must be some interactions in my profile...

But I'm reproducing it 100% after I restore the session and switch to the tab which is causing the problem.

I'm going to continue testing this with future versions of firefox...

Results: the crash is reproducible in firefox 53 (nightly).
(Reporter)

Updated

a year ago
Depends on: 1342897

Updated

a year ago
No longer depends on: 1342897
Duplicate of this bug: 1342897

Comment 3

a year ago
The reason is probably not a bug in firefox, but a buggy libfreetype-infinality-2.4.11-alt6.M70P.2 , which was tracked down by me thanks to the backtrace. I've done tests with other newer versions of this package (and without it, with using standard libfreetype), and the crash doesn't reproduce itself in those cases -- https://bugzilla.altlinux.org/show_bug.cgi?id=33181 .
(Reporter)

Comment 4

a year ago
The reason is probably not a bug in firefox, but a buggy libfreetype-infinality-2.4.11-alt6.M70P.2 -- https://bugzilla.mozilla.org/show_bug.cgi?id=1342894#c3 .
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.