If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-ons Manager ”Enable” button should not be clickable as long as permissions pop-up is displayed

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
P3
normal
RESOLVED WONTFIX
8 months ago
27 days ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 affected, firefox54 affected, firefox55 affected)

Details

(Whiteboard: [permissions] triaged)

Attachments

(2 attachments)

Created attachment 8841531 [details]
gif1.gif

[Affected versions]:
Firefox 54.0a1 (2017-02-27)
Firefox 53.0a2 (2017-02-27)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit


[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create extensions.webextPermissionPrompts and set it to true.
3.Install via sideloading method a webextension with permissions. 
4.After reopening the browser, open to Panel Menu [≡] and click on sideloading notification.
5.Click on Add-ons Manager “Enable” button (not the one from permissions pop-up).  


[Expected Results]:
Add-ons Manager “Enable” button is not clickable as long as permissions pop-up is displayed.


[Actual Results]:
The webextension can be enabled from Add-ons Manager “Enable” button even if permissions doorhanger is being displayed.

[Additional Notes]:
Due to Bug 1334096, while a webextensions is enabled avoiding the classical sideloading flow, the Add-ons Manager “Enable” button is not clickable as long as permissions pop-up is displayed. See screencast: https://www.screencast.com/t/0Xpjcarv

Comment 1

7 months ago
rhelmer: if we listen for the state, easily fixable
Priority: -- → P3
Whiteboard: [permissions] triaged

Comment 2

6 months ago
believe resolved in Nightly - so this should work now... would you mind retesting
Flags: needinfo?(vasilica.mihasca)
Created attachment 8859630 [details]
Animation.gif

Retested and it seems that this issue still reproduces on Firefox 55.0a1 (2017-04-19) and Firefox 54.0a1 (2017-04-18) under Windows 10 64-bit and Ubuntu 16.04 32-bit. 

Please see attached screencast.
Flags: needinfo?(vasilica.mihasca)
status-firefox55: --- → affected
Version: 54 Branch → Trunk

Comment 4

27 days ago
Given that we are planning on replacing the add-ons manager, I'm going to won't fix this for now.
Status: NEW → RESOLVED
Last Resolved: 27 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.