Closed Bug 1343101 Opened 4 years ago Closed 6 months ago

Decide how to handle structural differences for bookmark repairs

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

RESOLVED INVALID

People

(Reporter: lina, Unassigned)

References

Details

In bug 1317223, comment 93, we decided to only focus on items that aren't on the server (or that were explicitly requested; see bug 1317223, comment 117). This bug tracks repair for other kinds of corruption.

Deeper structural differences, like parent-child disagreements caused by a partial write, require more knowledge of the hierarchy before we can proceed. There are also complications for non-syncable items: in the worst case, we'll create orphans for items that shouldn't have been synced in the first place. Finally, it's possible that the responding client doesn't have a complete picture of the tree, either.
Priority: -- → P3

We killed the bookmark repairer and now just let dogear do its thing.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.