PDF viewer showing wrong page number

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: blakewolf, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 affected, firefox53 affected, firefox54 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8841905 [details]
bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170227030203

Steps to reproduce:

Open PDF file (does not happen on every file)


Actual results:

Open the PDF and see the wrong page number


Expected results:

PDF should start on page 1

Updated

2 years ago
Status: UNCONFIRMED → NEW
status-firefox51: --- → unaffected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
Component: Untriaged → PDF Viewer
Ever confirmed: true
Version: 54 Branch → 52 Branch

Comment 1

2 years ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=253395be59f635d21a4204539233613d7c35c2b9&tochange=33b4d8c005c4e68c11a10a366719593c6b40819e

fc8665420489	Ryan VanderMeulen — Bug 1315421 - Update pdf.js to version 1.6.304. r=bdahl
Blocks: 1315421
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Created attachment 8841946 [details]
adobe_reader.png
This is intended behaviour, since the PDF file uses Page Labels[1], please compare with the attached screen-shot from Adobe Reader.

--
[1] Refer to the PDF specification, http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/PDF32000_2008.pdf#G11.1696265.
No longer blocks: 1315421
Status: NEW → RESOLVED
Has Regression Range: yes → irrelevant
Last Resolved: 2 years ago
Keywords: regression
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.