Closed Bug 1343275 Opened 3 years ago Closed 3 years ago

Make the text control editor state's GetSelectionRange codepath a bit faster when going via the selection controller

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox54 --- wontfix
firefox55 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(2 files)

We can get rid of some virtual calls and refcounting and stuff.
Depends on: 1343037
MozReview-Commit-ID: 2v0r3jtua1O
Attachment #8842046 - Flags: review?(ehsan)
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #8842046 - Flags: review?(ehsan) → review+
Attachment #8842047 - Flags: review?(ehsan) → review+
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fc55ce02ba5
part 1.  Get selection faster in some nsTextEditorState methods.  r=ehsan
https://hg.mozilla.org/integration/mozilla-inbound/rev/32e54e6e8c02
part 2.  Use slightly faster APIs for getting the information we want out of a selection when converting it to a text-control selection range.  r=ehsan
The issue is the patches for bug 1345237.
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5df501fbf40d
part 1.  Get selection faster in some nsTextEditorState methods.  r=ehsan
https://hg.mozilla.org/integration/mozilla-inbound/rev/5b1392f47637
part 2.  Use slightly faster APIs for getting the information we want out of a selection when converting it to a text-control selection range.  r=ehsan
Flags: needinfo?(bzbarsky)
https://hg.mozilla.org/mozilla-central/rev/5df501fbf40d
https://hg.mozilla.org/mozilla-central/rev/5b1392f47637
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.