Closed Bug 1343357 Opened 3 years ago Closed 6 months ago

Assertion failure: startParams.mPath == endParams.mPath (unexpected path mismatch)

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox54 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: truber, Assigned: violet.bugreport)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

Attached image testcase.svg
The attached testcase causes an assertion failure in mozilla-central rev 1bc2ad020aee.

Assertion failure: startParams.mPath == endParams.mPath (unexpected path mismatch), at /home/worker/workspace/build/src/dom/svg/SVGMotionSMILType.cpp:430
#01: nsSMILAnimationFunction::InterpolateResult at dom/smil/nsSMILAnimationFunction.cpp:445
#02: nsSMILAnimationFunction::ComposeResult at dom/smil/nsSMILAnimationFunction.cpp:263
#03: nsSMILCompositor::ComposeAttribute at dom/smil/nsSMILCompositor.cpp:97
#04: nsSMILAnimationController::DoSample at dom/smil/nsSMILAnimationController.cpp:452
#05: nsSMILTimeContainer::Sample at dom/smil/nsSMILTimeContainer.cpp:185
#06: nsDocument::OnPageShow at dom/base/nsDocument.cpp:8907
#07: nsDocumentViewer::LoadComplete at layout/base/nsDocumentViewer.cpp:1063
#08: nsDocShell::EndPageLoad at docshell/base/nsDocShell.cpp:7637
#09: nsDocShell::OnStateChange at docshell/base/nsDocShell.cpp:7430
#10: nsDocLoader::DoFireOnStateChange at uriloader/base/nsDocLoader.cpp:1258
#11: nsDocLoader::doStopDocumentLoad at uriloader/base/nsDocLoader.cpp:841
#12: nsDocLoader::DocLoaderIsEmpty at uriloader/base/nsDocLoader.cpp:734
#13: nsDocLoader::OnStopRequest at uriloader/base/nsDocLoader.cpp:614
#14: mozilla::net::nsLoadGroup::RemoveRequest at netwerk/base/nsLoadGroup.cpp:636
#15: nsDocument::DoUnblockOnload at dom/base/nsDocument.cpp:8818
#16: nsDocument::UnblockOnload at dom/base/nsDocument.cpp:8743
#17: nsDocument::DispatchContentLoadedEvents at dom/base/nsDocument.cpp:5202
Flags: in-testsuite?
Flags: needinfo?(dholbert)
Still reproducible on trunk. Assertion goes back more than a year.
Marking as wontfix for 62, I'd take a low-risk patch for 63 if it doesn't come late in the beta cycle.

When there are lower-priority animations than a to-animation, our impl will
pass the current value from previous function to to-animation as start value,
this will cause a assertion failure because the start and end value will end up
in different paths. Our impl doesn't really support the interaction between
to-animation and lower-priority ones as described in the spec. Moreover, neither
Chrome nor Safari is compliant. Now we use the same behavior as Chrome and
Safari, i.e. ignore those lower-priority ones.

Assignee: nobody → violet.bugreport
Attachment #9050221 - Attachment description: Bug 1343357 - Ignore lower-priority animations if a to-animation is encountered → Bug 1343357 - Ignore lower-priority animateMotion if a to-animation is encountered
Duplicate of this bug: 1409911
Duplicate of this bug: 684780
Keywords: checkin-needed

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8854d4a16528
Ignore lower-priority animateMotion if a to-animation is encountered r=dholbert

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1474969

Thanks for fixing this, violet!

Flags: needinfo?(dholbert)
You need to log in before you can comment on or make changes to this bug.