Excessively large rule-processor-cache

RESOLVED DUPLICATE of bug 1320872

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1320872
a year ago
a year ago

People

(Reporter: erahm, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

In bug 1241470, comment 63 we see a memory report with an entry for 'layout/rule-processor-cache' that is 618 MB:

> ├────618.51 MB (16.53%) -- layout
> │    ├──617.88 MB (16.52%) ── rule-processor-cache
> │    └────0.63 MB (00.02%) ++ (2 tiny)

This looks like a bug either in the reporter or the implementation, but could just be poor interaction with ABP (or other add-ons). For example my browser is using 0.62 MB with ~70 tabs.

Discussing with dbaron on IRC he suggested that:
 1) It's possible the cache counts things that are also part of active documents
 2) it's worth seeing if
   a) there's a bug in expiration
   b) all/nearly all of the stuff in the cache is actually active

I'm not sure if that indicates adding elements that are active to the cache is the wrong thing to do, or we're actually double-reporting, or we just could use finer grained reporting to split out active elements.
Cameron, it looks like you added the cache in bug 77999, what do you think?
Flags: needinfo?(cam)
I think this was previously filed as bug 1320872.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320872
Flags: needinfo?(cam)
You need to log in before you can comment on or make changes to this bug.