Closed Bug 1343478 Opened 4 years ago Closed 4 years ago

Add missing CSS variable for debugger.html

Categories

(DevTools :: Shared Components, enhancement)

enhancement
Not set
normal

Tracking

(firefox54 fixed)

VERIFIED FIXED
Firefox 54
Tracking Status
firefox54 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

Details

Attachments

(1 file)

See issue: https://github.com/devtools-html/devtools-core/issues/220

debugger.html (or devtools-core in this case) defines the css variable --theme-comment-alt in its copy of variables.css but this was never ported to mozilla-central.

The values set in devtools core for this variable are:
- light: #ccd1d5
- dark: #5a6375
- firebug: #ccd1d5

Since the firebug theme "extends" the light theme and the same value is defined for both, we should only define it for light and dark.
Comment on attachment 8842356 [details]
Bug 1343478 - add missing css variables from devtools.html to variables.css;

https://reviewboard.mozilla.org/r/116224/#review117852
Attachment #8842356 - Flags: review?(jlaster) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e28df8c208a0
add missing css variables from devtools.html to variables.css;r=jlast
https://hg.mozilla.org/mozilla-central/rev/e28df8c208a0
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
I have reproduced this issue on Firefox nightly according to (2017-03-01)

Fixing bug is verified on Latest Developer Edition--- Build ID: (20170427004028),User Agent: Mozilla/5.0 (Windows NT 6.1; rv:54.0) Gecko/20100101 Firefox/54.0

Tested OS-- Windows7 32bit
[testday-20170428]
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.