bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mozilla etherpads extremely slow with e10s and spell checker enabled

RESOLVED DUPLICATE of bug 1303749

Status

()

Core
DOM: Content Processes
RESOLVED DUPLICATE of bug 1303749
a year ago
a year ago

People

(Reporter: till, Unassigned)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

(URL)

(Reporter)

Description

a year ago
The spell checker seems to use sync IPC messages. A lot of them.

With the spell checker and e10s enabled, there's a pause of several seconds during initialization of https://public.etherpad-mozilla.org/p/berlin-lunch, right after the pad's content shows up. With either disabled, that pause goes away. See the profile at https://perfht.ml/2mPfFC1. (But note that that also is very slow, see https://github.com/devtools-html/perf.html/issues/172)

Perhaps it's possible to batch spell checking requests, or make the messages async?
Blake has a patch to mitigate the problem under bug 1303749 I think. Could you please check if it helps and dupe the bug if it's the same issue?
(Reporter)

Comment 2

a year ago
(In reply to Gabor Krizsanits [:krizsa :gabor] from comment #1)
> Blake has a patch to mitigate the problem under bug 1303749 I think. Could
> you please check if it helps and dupe the bug if it's the same issue?

Ah, I didn't find that. I don't have time to apply the patch, build, and re-check, I'm afraid. The issue is so obviously the same though that I'll just dupe this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303749
You need to log in before you can comment on or make changes to this bug.