Cloning a bug causes an invalid cloned_bug_id param when creating the new bug.

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Bug Creation/Editing
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: markh, Assigned: dkl)

Tracking

Production

Details

(Reporter)

Description

4 months ago
STR:
* In some bug select "Clone bug, as a clone in a different product"
* You are asked to select a component - select one.

Expected:
* New cloned bug is shown.

Actual:
* Page with error message "'bug' is not a valid bug number nor an alias to a bug."

The issue appears to be that the URL used to select a component is always https://bugzilla.mozilla.org/enter_bug.cgi?format=__default__&cloned_bug_id=bug - the tail of that URL should be a bug number. If you edit the URL and replace "bug" with the bug number, things work.
(Assignee)

Updated

4 months ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 months ago
To https://github.com/mozilla-bteam/bmo.git
   9561143..38549ea  master -> master
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1344683
You need to log in before you can comment on or make changes to this bug.